Onkyo M506RS problems... - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd September 2011, 05:09 AM   #1
Recvery is offline Recvery  United States
diyAudio Member
 
Join Date: Aug 2011
Default Onkyo M506RS problems...

Helloooooo audioooo loversss

I've owned my onkyo m506rs for about 3 years now and ive experienced this problem once before. It seemed to solve itself so I forgot the issue even existe.... UNTIL today

My problem is when i turn the amp on it seems to have to stages (when working correctly). It clicks on and glows orange in the front panel for a moment then clicks again and should glow green (my green lights dont work so its just dark). The usual orange to green is some sort of powering on stage before it is ready. Today, it does not leave the orange phase and it will not produce sound I use the onkyo p306RS preamp (no problems with it), and i do not have the super servo cable installed due to the rarity making them so hard to find. I also do not have the ground wire installed, mainly because I dont know what or how to use it. I would very much appreciate anyone taking the time to reach out and assist me as i love my onkyo with a passion and i would love to gain information on the ins and outs of her!!!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MiniWatt N3 problems, oscillation thumping and RF/motor problems. Destroyer OS. Tubes / Valves 18 6th July 2010 12:14 AM
Problems in Onkyo receiver carlmart Solid State 1 18th November 2009 04:54 PM
Problems in Onkyo receiver carlmart Solid State 0 18th November 2009 10:31 AM
Onkyo help !! large Solid State 0 29th January 2009 01:24 PM
Onkyo CD Player Problems Fat Man Digital Source 0 13th March 2004 11:37 AM


New To Site? Need Help?

All times are GMT. The time now is 04:48 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2