Ucd400hg blew after 4 years - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th August 2011, 11:12 AM   #1
diyAudio Member
 
Join Date: Jun 2003
Location: Singapore
Default Ucd400hg blew after 4 years

My ucd400hg blew a few days ago. 56v dc into my harbeth - burnt coil. Intermittent blinking now on the onboard led. Any ideas what's wrong?

I measured the power supply; no issues there.
  Reply With Quote
Old 10th August 2011, 01:44 PM   #2
Javin5 is offline Javin5  Switzerland
diyAudio Member
 
Join Date: Mar 2006
Location: Switzerland
Hard to say after the fact. Maybe some temporary, unusually high mains voltage?

Burnt coil? Does anyone know if the UcD has some built-in protection that should have prevented this?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UCD400HG - lowering gain imagemachine Class D 5 14th December 2010 06:07 PM
hypex ucd400hg back Swap Meet 5 12th April 2010 01:37 PM
how to briged 2x ucd400hg slr 5000 Class D 4 2nd October 2008 09:08 AM
UcD400hg monoblocks done croger Class D 25 24th March 2008 10:50 AM
Hypex UCD400HG Comments ngiachin Class D 7 19th September 2007 09:26 AM


New To Site? Need Help?

All times are GMT. The time now is 01:59 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2