Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

unsuccessful t-amp mod....please help
unsuccessful t-amp mod....please help
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd August 2011, 12:47 AM   #1
amiti is offline amiti  Israel
diyAudio Member
 
Join Date: Jul 2010
Default unsuccessful t-amp mod....please help

I tried to mod my SI t-amp. I replaced C10 capacitor and followed the stealth mod from here only without exchanging the volume pot. The process was very tedious with a few soldering problems. Eventually I thought I managed to set everything as instructed but when I hooked the power again some ticking started and went on constantly. These clicks are heard from both channels and in speed of a click every half a second more or less. Does anyone have a clue for what may be causing this?
  Reply With Quote
Old 2nd August 2011, 11:45 PM   #2
nigelwright7557 is offline nigelwright7557  United Kingdom
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
The clicking is the amp has gone into protect mode.
Reason could be overcurrent detected.
__________________
PCBCAD51 pcb design software. 2018 version out now. https://www.ebay.co.uk/sch/i.html?_f...nload&_sacat=0
  Reply With Quote
Old 3rd August 2011, 12:21 AM   #3
amiti is offline amiti  Israel
diyAudio Member
 
Join Date: Jul 2010
Thank you Nigel.This means the power circuit was shorted?
  Reply With Quote

Reply


unsuccessful t-amp mod....please helpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
T-amp POWER AMP Mod + VERY LOUD ramdog12345 Class D 7 25th April 2007 01:00 PM
mod a L&R sum output to stereo signal? compact7 Subwoofers 0 3rd April 2006 04:28 AM
B&W 801 matrix series 2 crossover mod help musicalmaniac Multi-Way 0 10th January 2005 01:17 AM
amp mod vlljpior Tubes / Valves 3 28th October 2004 04:34 PM
class H chip kit,unsuccessful mikee12345 Chip Amps 4 26th February 2004 09:21 AM


New To Site? Need Help?

All times are GMT. The time now is 01:28 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki