GK MB2-500 Repair: Preliminary Q's - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th July 2011, 12:04 AM   #1
diyAudio Member
 
Join Date: Apr 2011
Default GK MB2-500 Repair: Preliminary Q's

Good morning,

I am about to replace the icepower 125 power amp module in my Gallien Krueger MB2-500 because it has been stuck in safety mode for ~6 months now! It has been this long for me to source a cheap enough replacement 125. Now, I checked the jumper from the AUX power-in on the icepower and traced it back to the GK preamp where it connects to. The transistor there looks, well, interesting. A little smokey in colour and some of the writing has gone. Here are some pic's.

A shot from the back:
Click the image to open in full size.

Here's a front shot - sorry if the quality is bad - but its not much better in real life!
Click the image to open in full size.

Here's a comparison with a nearby transistor, notice it's not as dusty:
Click the image to open in full size.

So, could this transistor be dead? Is it possible to test without removing it from the board?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Got Onkyo M-504 amp out of repair yay! 2 Q's saabracer23 Solid State 8 29th May 2012 07:40 AM
Nakamichi mb2 problem transamz2000 Digital Source 4 14th January 2011 05:02 PM
plans for peavey mb2 tmkart50 Multi-Way 0 21st December 2010 09:30 AM
JL Audio 500/1 repair info Bertje Car Audio 11 30th October 2009 12:52 PM
JL Audio 500/1 Amplifier Repair Help Audioguy564 Car Audio 10 27th August 2009 02:24 AM


New To Site? Need Help?

All times are GMT. The time now is 02:53 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2