Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

My design L20D IRS2092+IRFI4020H  200W8R
My design L20D IRS2092+IRFI4020H  200W8R
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th December 2012, 09:19 PM   #601
Stammheim is offline Stammheim  Germany
diyAudio Member
 
Join Date: Jul 2012
Yes of course I know... but that's what my oscilloscope says... the speakers say hum...
  Reply With Quote
Old 25th December 2012, 11:47 AM   #602
doctordata is offline doctordata  Australia
diyAudio Member
 
doctordata's Avatar
 
Join Date: Apr 2010
Location: Brisbane
My design L20D IRS2092+IRFI4020H  200W8R
Quote:
Originally Posted by Stammheim View Post
Yes of course I know... but that's what my oscilloscope says... the speakers say hum...
I was just kidding , but you probably have some ground loop problem , Be sure to use a star ground , all grounds to one point at the PSU ( see my system picture in my previous post) I had a little hum in my 5 x L15d system in the beginning , when I wired the speaker grounds direct to the L15D boards . after I changed the speaker ground wiring directly to the star point at the PSU the system was totally quiet .

Cheers

Rens
__________________
If you measure, you know; if you guess, you don't
  Reply With Quote
Old 25th December 2012, 01:05 PM   #603
exflaco is offline exflaco  Armenia
diyAudio Member
 
Join Date: Mar 2005
Location: Santa Fe
heyyyyy merry Christmas 4 All diyers
  Reply With Quote
Old 27th December 2012, 07:10 AM   #604
luka is offline luka  Slovenia
diyAudio Member
 
luka's Avatar
 
Join Date: Sep 2005
Location: in Slovenia :)
My design L20D IRS2092+IRFI4020H  200W8R
Quote:
Originally Posted by Stammheim View Post
Do I get you right? Your speakers produce hum, too? I'll try to measure the SMPS's hum with some resistors, so without the hum from the amps. Doesn't anybody have similar experiences or some measurements?

Are threre any mods so solve it?
well yes, but not because of the switching amp. you can't hear that freq. of several 100kHz. my hum if I would put it like that is because of not really good ground between computer, power outlet and amp and so on. with no signal, no cable on input, you can't hear anything
__________________
home page @ http://www.classdaudio.tk/ @ 24/7 all year long
I FEEL SLOVENIA
  Reply With Quote
Old 27th December 2012, 08:19 AM   #605
Stammheim is offline Stammheim  Germany
diyAudio Member
 
Join Date: Jul 2012
I know what you mean and I don'r really know the problem. I also know I'm not able to hear > 16 - 18kHz. But I can hear the hum from the speakers really good, and after I simply wired only one module and solved any possible loops, I have no idea instead. Is it possible, that the SMPS' s ripple / AC is too high and so the mosfets or other vomponents are oscillating?
  Reply With Quote
Old 27th December 2012, 09:48 AM   #606
peterhenk is offline peterhenk  Netherlands
diyAudio Member
 
Join Date: Apr 2008
Quote:
Originally Posted by doctordata View Post
I was just kidding , but you probably have some ground loop problem , Be sure to use a star ground , all grounds to one point at the PSU ( see my system picture in my previous post) I had a little hum in my 5 x L15d system in the beginning , when I wired the speaker grounds direct to the L15D boards . after I changed the speaker ground wiring directly to the star point at the PSU the system was totally quiet .

Cheers

Rens
Hi Rens,

So to make this clear for me

Your speaker ground goes both (first) to the common star ground and (then) to the minus binding post on the L15d.

I have some his that I would like to tackle, this is by far the easy way out.

Thank you

Peter
  Reply With Quote
Old 27th December 2012, 10:30 AM   #607
doctordata is offline doctordata  Australia
diyAudio Member
 
doctordata's Avatar
 
Join Date: Apr 2010
Location: Brisbane
My design L20D IRS2092+IRFI4020H  200W8R
Default Noise

I wired my amp as described in post 47
http://www.diyaudio.com/forums/class...ml#post2687712
That solved my ( modest) hum problem .
Dont think it will make any difference with noise . My amps have very little noise , only audible with the ear in front of my very sensitive Tannoys .

Cheers ,

Geniet van de oliebollen ! (Enjoy the Oil Balls!)
Rens
__________________
If you measure, you know; if you guess, you don't

Last edited by doctordata; 27th December 2012 at 10:49 AM. Reason: Translating Dutch phrase
  Reply With Quote
Old 27th December 2012, 10:38 AM   #608
peterhenk is offline peterhenk  Netherlands
diyAudio Member
 
Join Date: Apr 2008
Default Begrepen

Hi Rens,

I use the L15d-pro. Just searched for the recommended wiring, as it is different because of the incorporated speaker protection.

So your solution will not work for me.

Oliebollen / appelflappen: we zullen er zeker van genieten!!

Groet
Peter

Last edited by peterhenk; 27th December 2012 at 10:49 AM. Reason: new information
  Reply With Quote
Old 27th December 2012, 11:00 AM   #609
doctordata is offline doctordata  Australia
diyAudio Member
 
doctordata's Avatar
 
Join Date: Apr 2010
Location: Brisbane
My design L20D IRS2092+IRFI4020H  200W8R
Default His , Hum or what

Quote:
Originally Posted by peterhenk View Post
Hi Rens,

I use the L15d-pro. Just searched for the recommended wiring, as it is different because of the incorporated speaker protection.

So your solution will not work for me.

Oliebollen / appelflappen: we zullen er zeker van genieten!!

Groet
Peter
Hi Peter ,

Do you have noise ( Hiss) or hum in your system , I don't have a schematic of the l15D pro with DC protection , but have a pretty good idea how it is wired on the PCB and I think there will be a problem in a multi amp system on one PSU with this board .Do you have the schematic ?

Cheers ,

Rens
__________________
If you measure, you know; if you guess, you don't
  Reply With Quote
Old 27th December 2012, 11:53 AM   #610
peterhenk is offline peterhenk  Netherlands
diyAudio Member
 
Join Date: Apr 2008
Hi Rens,

The schematics of the wiring.

I use a connexelectronics smps500r to feed them.

My grounding is floating as I have no grounding in my sockets.

Peter
Attached Images
File Type: png l15d wiring.png (222.9 KB, 963 views)
  Reply With Quote

Reply


My design L20D IRS2092+IRFI4020H  200W8RHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Sure IRS2092 IRFI4020H part # AA-AB32291 HiroPro Class D 35 30th April 2017 06:14 AM
Part Supliers for IRS2092 and IRFI4020H-117P KrishanthaSampath Class D 2 22nd February 2014 01:10 PM
IRS2092 own design elektryk Class D 30 5th February 2014 08:30 AM
L20D IRS2092 basic questions egoaudio Class D 7 8th October 2011 02:46 PM
Design help needed for IRS2092 cmhadley Class D 1 2nd January 2009 11:06 PM


New To Site? Need Help?

All times are GMT. The time now is 06:59 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki