MRD-M1005 fried - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th May 2011, 07:15 AM   #1
Dogwizz is offline Dogwizz  Australia-Aboriginal
diyAudio Member
 
Join Date: Feb 2008
Send a message via MSN to Dogwizz
Default MRD-M1005 fried

hi i own a mrd-m1005 i accidently knocked a wire and shorted the negative speaker input with a positive power wire or negative power wire 1 of them and my amp now displays cur all the time what should i be testing on the board? nothing looks blown i only have a multimeter to test with im a bit of a noob but i can change over transistors. thanks any help will be great
  Reply With Quote
Old 13th May 2011, 09:04 PM   #2
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
You can check output transistors first.
Check for shorts.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 13th May 2011, 09:34 PM   #3
Dogwizz is offline Dogwizz  Australia-Aboriginal
diyAudio Member
 
Join Date: Feb 2008
Send a message via MSN to Dogwizz
thanks 2 transistors are showing a fully closed circuit between the pins so im guessing thats my problem anyway ive ordered every transistor and im going to replace the lot in 1 go thanks again
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine mrd-m1005 schematics for repair Mr.Monkeys Car Audio 3 8th April 2011 09:01 PM
So I Took Apart My Alpine MRD M1005...need insight please! onyxaltezza Car Audio 6 4th May 2010 03:20 AM
Alpine mrd-m300 elec972 Car Audio 16 11th March 2010 09:35 PM
Alpine mrd-m501 Repair dj_square- Car Audio 2 31st August 2009 05:15 AM
Alpine MRD-605 no output cobology Class D 0 21st February 2009 12:45 AM


New To Site? Need Help?

All times are GMT. The time now is 02:48 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2