diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   Hypex Ucd400 repair - where to start? (http://www.diyaudio.com/forums/class-d/188298-hypex-ucd400-repair-where-start.html)

Wa 3rd May 2011 12:23 AM

Hypex Ucd400 repair - where to start?
 
Hi,

I have a 2 way amp for guitar; coldamp 400 for the bottom end, hypex 400 for the top end, marchand xm1 crossover - powered by a coldamp smps - 5.5 ohm load, and 5.3 ohm load

it has been happily doing its job for 2 years, and just lost the top end. the hypex module is putting out a strained/distorted wisp of a sound - i have ruled out everything before and after the module, and speakers are fine. voltage is fine, lines in and out are fine when swapped to the coldamp.

i have a 5 digit dvm, an oscilloscope etc, just don't know what to check first. what is the most fragile component on these hypex ucd400 modules?

the only thing that changed was i ran the guitar direct into the amp (when i forgot the preamp power supply at home) for one gig. the piezo bridge kicks out some very low frequencies, but that should've been covered by the input caps on the crossover circuit

any starting point would be a great help, thanks

wa

ssanmor 3rd May 2011 10:01 AM

If it has less or just two years it should be covered by warranty, perhaps you can ask Hypex for help.


All times are GMT. The time now is 09:29 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2