SI 5066 pulse in L channel then failure - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th April 2011, 02:06 PM   #1
diyAudio Member
 
Join Date: Sep 2006
Default SI 5066 pulse in L channel then failure

Are T-amps particularly sensitive to line voltage spikes?

One channel of my SI 5066 failed the other day. It's been in use daily for at least a year, but yesterday, shortly after powering it on, I started to hear 'pops' from the left channel every few min., and then the channel failed completely. FWIW, no other electronics (including other components - preamp, tuner - on the same power strip) failed in our house during this episode.

How common is this, and is it fatal?

Thanks in advance for any advice!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SI 5066 problem (supply present at output) DcibeL Class D 7 9th March 2006 04:53 AM
Donate to diyAudio for SI T amp. #5066 sklimek Swap Meet 5 12th August 2005 03:40 AM
SI 5066 Input Cap Option Panelhead Class D 10 24th June 2005 05:15 AM
filtering switched mode PSU for SI 5066 amp supply jives11 Parts 0 24th January 2005 09:19 PM


New To Site? Need Help?

All times are GMT. The time now is 05:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2