Guide to build Hypex Modules - Page 9 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th June 2011, 05:14 PM   #81
diyAudio Member
 
eclectic2k's Avatar
 
Join Date: Nov 2005
Location: Silicon Valley
Quote:
Originally Posted by alvinlim View Post
Suggest you do a search on this in this website and hypx. UCD/Bruno recommends floating the ground. I have done this before and it works fine.
You can float it from AC safety ground yes, but you normally still need 0V reference return for those things that are not balanced. (that is, your "GND" pin on UcD should still be connected back to the supply, if not to AC GND) Anyway, I was trying to solve a problem that did not exist, as it had seemed at the time that his enable line was not seeing 0V.

Then we realized the issue was that he did not have enough voltage. (having overlooked the need for +/-50V) It maybe the enable line was OK after all.
Quote:
Originally Posted by Duffy Moon View Post
With the supplies in series, both modules work nicely (thanks eclectic2k). Perhaps the old modules worked with a floating ground, but the newer ones do not?
great to hear it worked out!
  Reply With Quote
Old 20th June 2011, 05:39 PM   #82
diyAudio Member
 
Join Date: Jul 2008
Location: Surrey, UK
Quote:
Originally Posted by eclectic2k View Post
great to hear it worked out!
I have to say that they do sound marvellous, even through an old pair of Goodmans Magnum K speakers.
  Reply With Quote
Old 15th July 2011, 03:32 PM   #83
diyAudio Member
 
Join Date: Dec 2005
Location: Zürich
Default it works....allmost!!

hello together
After a prolonged stay abroad, I have finally time for my project.
I have finally done it ... it runs. With your help I did it. Thank you for that. Now I have a little problem. One of the 12 HxR regulator (on the right UCD module - HPR12) does not work, has no light. Here you can hear a small click and the blue LED flashes ... and I think something tastes like burnt. I immediately turned off. Does anyone know what could be the problem?

Thank you for your help
Attached Images
File Type: jpg Foto.JPG (509.8 KB, 432 views)
  Reply With Quote
Old 16th July 2011, 04:18 PM   #84
diyAudio Member
 
Join Date: Dec 2005
Location: Zürich
...Nobody an idea?
Is this HxR Modul gone or do i have to check/try something else?

Thanks for an answer
  Reply With Quote
Old 16th July 2011, 05:50 PM   #85
diyAudio Member
 
eclectic2k's Avatar
 
Join Date: Nov 2005
Location: Silicon Valley
Quote:
Originally Posted by souldriver View Post
...Nobody an idea?
Is this HxR Modul gone or do i have to check/try something else?

Thanks for an answer
Nope, no idea. There is either a short circuit, an open circuit (bad solder?), or the regulator is toast.

If you bought the UcD with HxR's pre-installed, I suggest you email Hypex and possibly arrange a return for repair. (maybe a charge for repair though)

If you installed the HxR's yourself, I suggest rechecking solder joints and such. Maybe check with an ohmmeter all the power rails. And of course you can always arrange a return to Hypex for repair. (I had to have a UcD repaired by them myself. Aside from expensive shipping they were good about it)

good luck.
  Reply With Quote
Old 16th July 2011, 07:29 PM   #86
diyAudio Member
 
Join Date: Dec 2005
Location: Zürich
thanks a lot eclectic
The HxR have been pre-installed. i will send a email to Hypex and see what they think about that. il keep you informed.

have a nice time and thanks again
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New hypex modules for sale ultra Swap Meet 13 19th May 2014 07:58 AM
Question for those who have tried hypex smps with hypex modules avian Class D 12 3rd March 2009 09:30 AM
WTB: UcD modules from Hypex iwok Swap Meet 0 26th October 2007 07:50 AM
New modules from Hypex nilsomat Class D 6 30th May 2007 11:24 AM
Hypex UCD 180AD - 5 New Modules Stevenacnj Swap Meet 8 8th September 2005 07:38 PM


New To Site? Need Help?

All times are GMT. The time now is 03:09 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2