Cant find + & - on a Helder tube preamp?? - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th February 2011, 06:16 PM   #1
diyAudio Member
 
Join Date: Feb 2010
Default Cant find + & - on a Helder tube preamp??

Anyone who can help me pls?

The green terminal is 12 volt + & - but i dont who is who?

NEW tube pre-amp MKIII 12AU7 fully assembled su eBay.it Amplifiers, Home Audio, Electronics


Hans Erik

Click the image to open in full size.
Uploaded with ImageShack.us

Click the image to open in full size.
Uploaded with ImageShack.us
  Reply With Quote
Old 18th February 2011, 06:35 PM   #2
diyAudio Member
 
firechief's Avatar
 
Join Date: Sep 2008
Location: Near Seattle Wa
You have a bunch of electrolydic caps on the board. The negative side of the caps should be marked clearly. If you find that they are all conected to a large trace that is most likely ground for the board. The trace should also go to one of the pins on the green connector. An ohmeter would be verry usefull to confirm this, as would be a schematic. I also see a three terminal regulator, what is the number on it?
  Reply With Quote
Old 18th February 2011, 06:42 PM   #3
diyAudio Member
 
Join Date: Feb 2010
Quote:
Originally Posted by firechief View Post
You have a bunch of electrolydic caps on the board. The negative side of the caps should be marked clearly. If you find that they are all conected to a large trace that is most likely ground for the board. The trace should also go to one of the pins on the green connector. An ohmeter would be verry usefull to confirm this, as would be a schematic. I also see a three terminal regulator, what is the number on it?

It looks like the ground "print" is on the right side on the caps
When i see the PCP through a light the ground "print" is going in on the right side on the green terminal. But the area under the terminal is not possible to see anything?

I am afraid of damaging the preamp?
  Reply With Quote
Old 18th February 2011, 07:48 PM   #4
diyAudio Member
 
Join Date: Feb 2010
It was the left one. Now its playing. Case closed

The preamp adds a lot of gain and a smoother sound with a little bit more body.

Click the image to open in full size.
Uploaded with ImageShack.us
  Reply With Quote
Old 18th February 2011, 08:24 PM   #5
diyAudio Member
 
firechief's Avatar
 
Join Date: Sep 2008
Location: Near Seattle Wa
  Reply With Quote
Old 8th July 2011, 09:24 PM   #6
juanito is offline juanito  Europe
diyAudio Member
 
juanito's Avatar
 
Join Date: Nov 2006
Quote:
Originally Posted by superlian View Post
It was the left one. Now its playing. Case closed

The preamp adds a lot of gain and a smoother sound with a little bit more body.

Click the image to open in full size.
Uploaded with ImageShack.us
Hi Superlian,

which source do you use with this combination? I'm planing to use this preamp with the TA2020 Helder hifi.

By the way, does the pre amp and TA202 board use the same power supply? I have a SMPS 14 V DC now, do I have to get an extra 12V DC for the pre amp section, or can I use the same one?

Sorry if this question may sound stupid...
Cheers
  Reply With Quote
Old 11th July 2011, 12:50 PM   #7
diyAudio Member
 
Join Date: Feb 2010
Quote:
Originally Posted by juanito View Post
Hi Superlian,

which source do you use with this combination? I'm planing to use this preamp with the TA2020 Helder hifi.

By the way, does the pre amp and TA202 board use the same power supply? I have a SMPS 14 V DC now, do I have to get an extra 12V DC for the pre amp section, or can I use the same one?

Sorry if this question may sound stupid...
Cheers
The preamp doesnt need much power. It is sufficient to share the SMPS with the t-amp. I dont know if 14 volt is to much for the preamp. I think you should use max 13 volt until you get correct info from Arjen Helder.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Helder MKII TA2020 Amp PSU Wiring Obe1 Class D 10 22nd January 2014 02:33 PM
Curing Arjen helder amp power off pop !!! onis_uk Class D 30 19th August 2010 03:17 PM
FA: Eico HF-85 Tube Preamp & HFT-90 Tube Tuner joe-electro Swap Meet 0 31st May 2009 05:14 PM
Tube amp find in old theater MPM Tubes / Valves 8 22nd December 2007 01:03 AM


New To Site? Need Help?

All times are GMT. The time now is 12:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2