Class D Amp with LM566,LM393 and 2XIRF530 - Page 53 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th March 2013, 04:01 PM   #521
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
D200 on SMPS

Smps & Apex D200 - YouTube
  Reply With Quote
Old 30th March 2013, 04:12 PM   #522
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by jlester87 View Post
Hi Azmi,

I've traced the circuit for the protection. It uses 2 of the NAND gates(pins 1 to 6) for shutdown control, the input for the pins 1 and 2 of 74HC00 (encircled in the attached pic) is normally "low", when there's a voltage across the current sensing resistor, pins 1 and 2 will go "high", resulting pin 6 to output high then triggers the SD pin of IR2110.

But there's no delay for the trigger, the 47uf connected in pin 5 is only for startup delay.
I'm afraid the protection will loop fast (assuming current sensing in speaker out works) and might lead to mosfet destruction.
Protect have delay with 2k2 and 220pF for activate, 47uF and 10k for startup delay is also for protect release delay.
Regards
  Reply With Quote
Old 3rd April 2013, 11:59 AM   #523
PetruV is offline PetruV  Romania
diyAudio Member
 
Join Date: Dec 2012
Location: Bucuresti
I am no longer building this amp,its very complicated so im going with an apex b500.
It seems as this thread lost popularity when i stopped posting
__________________
I know everything but do nothing
  Reply With Quote
Old 6th April 2013, 12:14 PM   #524
44250 is offline 44250  Serbia
diyAudio Member
 
44250's Avatar
 
Join Date: Jan 2011
Location: Ugrinovci-Zemun-BELGRADE
Send a message via AIM to 44250
Quote:
Originally Posted by PetruV View Post
I am no longer building this amp,its very complicated so im going with an apex b500.
It seems as this thread lost popularity when i stopped posting
that's too bad,because you contributed so much to this thread...
.
i have decided to try this amplifier,i have read this thread from the page 43 up to here but will not start assembling it untill i read it from a page 1.
  Reply With Quote
Old 10th April 2013, 07:54 AM   #525
PetruV is offline PetruV  Romania
diyAudio Member
 
Join Date: Dec 2012
Location: Bucuresti
Quote:
Originally Posted by 44250 View Post
that's too bad,because you contributed so much to this thread...
.
i have decided to try this amplifier,i have read this thread from the page 43 up to here but will not start assembling it untill i read it from a page 1.
its one heck of a chalenge to build these ,so make sure you are prepared not like me who put it aside since it requires too many parts
__________________
I know everything but do nothing
  Reply With Quote
Old 10th April 2013, 03:24 PM   #526
44250 is offline 44250  Serbia
diyAudio Member
 
44250's Avatar
 
Join Date: Jan 2011
Location: Ugrinovci-Zemun-BELGRADE
Send a message via AIM to 44250
there are not so many parts in this amplifier,but main thing that can be an opsticle is if it doesn´ t work from first plugging in i am in trouble because only thing that i can do is to measure the frequency and current/voltage by my DMM - i also don´t have osciloscope. all i can do is to read this thread and hope for the best. more than a few people did it,i hope to be one of them...
  Reply With Quote
Old 10th April 2013, 05:09 PM   #527
PetruV is offline PetruV  Romania
diyAudio Member
 
Join Date: Dec 2012
Location: Bucuresti
Quote:
Originally Posted by 44250 View Post
there are not so many parts in this amplifier,but main thing that can be an opsticle is if it doesn´ t work from first plugging in i am in trouble because only thing that i can do is to measure the frequency and current/voltage by my DMM - i also don´t have osciloscope. all i can do is to read this thread and hope for the best. more than a few people did it,i hope to be one of them...
yep know that feeling,it happens a lot to me,if it dosent work no one can help you,i tried building many amps but only one worked,for the others people didnt know how to help me
__________________
I know everything but do nothing
  Reply With Quote
Old 10th April 2013, 05:24 PM   #528
44250 is offline 44250  Serbia
diyAudio Member
 
44250's Avatar
 
Join Date: Jan 2011
Location: Ugrinovci-Zemun-BELGRADE
Send a message via AIM to 44250
i have built 10 amplifiers up till now,all ab and one b-class and all of them work well as they should. d-class is something a bit new to me and more demanding one-from tehnical point of view and from needed equippment point of view.

i will try it,so we will see what will happen´.
  Reply With Quote
Old 17th April 2013, 09:33 AM   #529
PetruV is offline PetruV  Romania
diyAudio Member
 
Join Date: Dec 2012
Location: Bucuresti
Good look,were your amps on pcbs like these or on perfboard?
__________________
I know everything but do nothing
  Reply With Quote
Old 17th April 2013, 01:37 PM   #530
norazmi is offline norazmi  Malaysia
diyAudio Member
 
Join Date: Feb 2008
use main supply in series with bulb when first time power on . btw if your component is the same what apex showing and mount them correctly, dont be rush, check every component and trace, im sure this amp will work nicely. most ppls do modified with another value component because they dont have exactly component listed by apex, so there is the problem, when u want build class D amp who already testing and running, you need to have commitment for all part list with the same value and type.

p/s - there is no shortcut to make it more easy
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring an AB class amp to work in pure A class jrme Tubes / Valves 5 23rd February 2010 06:31 PM
Can a Class AB PP amp be said to be operating in Class A at low signal levels? ray_moth Tubes / Valves 19 23rd January 2009 07:52 PM
why p-p amp RL for class B is 1/2 the class A load? walter33333 Tubes / Valves 2 12th February 2008 04:56 PM
Class D amp? Digital amp? or traditional Class A? rockytro Solid State 21 23rd May 2006 12:40 AM


New To Site? Need Help?

All times are GMT. The time now is 11:37 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2