problem with Bryston amplifier 9bst - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th October 2010, 12:45 PM   #1
diyAudio Member
 
Join Date: Oct 2010
Default problem with Bryston amplifier 9bst

hello
I have a problem with the amplifier 9bst, I have broken two channels and I can not find the component.
these components are br6521 and br6522, I can not find the datasheet and equivalent.
I can lend a hand
thanks
  Reply With Quote
Old 2nd November 2010, 10:26 AM   #2
Corax is offline Corax  Germany
diyAudio Member
 
Join Date: Feb 2005
Location: south of lower saxon
Those are relabeled transistors.

Use the search function with "br6521" and/or "br6522" and you'll be able to find at least four threads in this forum where replacements are mentioned.
  Reply With Quote
Old 2nd November 2010, 03:08 PM   #3
diyAudio Member
 
Join Date: Oct 2010
good morning
I already tried with the search in fact there are already discussions about it.
I already tried to replace the components with the MJE MJE 15031 and 15030 but I jump 2 22ohm resistors R26 and R83 precisely changing the sound source.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Having problem with a Bryston 3B Unique Solid State 4 7th November 2013 08:35 AM
Super nice Bryston 3B Amplifier for sale adowd Swap Meet 7 17th June 2010 10:08 PM
sub amplifier problem testarossa2k Subwoofers 4 25th August 2006 06:36 PM
Modifying a Bryston 2B amplifier .. JinMTVT Solid State 3 26th July 2004 08:04 AM
Amplifier problem empire Parts 0 4th April 2003 09:43 AM


New To Site? Need Help?

All times are GMT. The time now is 04:40 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2