Soundtech PS802 Amp.. Need help - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th September 2010, 08:46 PM   #1
diyAudio Member
 
Join Date: Sep 2010
Unhappy Soundtech PS802 Amp.. Need help

I'm having a problem with Sound tech PS802 amp. It's displaying the Protect Red light (blinks slow) My mixer led's bouncing no sound coming out of the speakers. If connections were wiggled you'd get a crackle/ static sound out of speakers.
Is there a reset? Any Help would be greatly appreciated. Thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with soundtech ps802 amplifier bt242 Solid State 3 12th October 2013 02:14 PM
SoundTech PS1300/1600 info artcarmo Solid State 0 1st March 2009 06:33 PM
Info re Soundtech powerone tube amp hedalfa Tubes / Valves 1 13th April 2006 01:55 PM
need help with Soundtech ps802 amplifier bt242 Class D 1 25th July 2005 06:49 AM


New To Site? Need Help?

All times are GMT. The time now is 09:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2