Lepai LP2020 dead on arival - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd September 2010, 11:40 AM   #1
Banned
 
Join Date: Jan 2005
Default Lepai LP2020 dead on arival

My Lepai LP2020 arived today and it was dead out of the box! It was ticking so i opened it up and found that it had already been modified!

Seller miyashop claimed in his ad on ebay that it was 100% brand new which turned out to be pure and utter **!! So i'd stay away from him if i were you.

I have contaced seller about the issue and requested i get a new TA2020 or a whole new amp free of charge.
  Reply With Quote
Old 3rd September 2010, 12:11 PM   #2
Banned
 
Join Date: Jan 2005
Turns out it was my power supply tha dident wanna work properly after the voltage mod.

Amp is working ok on a 7812 tho it makesa huge PLOMP on power on which i guess are the input caps.
  Reply With Quote
Old 3rd September 2010, 02:42 PM   #3
diyAudio Member
 
Join Date: Oct 2009
Location: DC Area
Thanks for the head's up. I got a a Muse M15 with an M20 faceplate and some sloppy solder work that cause the amp to loose a channel. Had to do some re-soldering to get it solid. The traces are a micron apart, so just the slightest mess up and you have a short. Feel sorry for the folks that buy these and can't fix them.
__________________
WHALEMAN
The Cathedral Speaker Co.
  Reply With Quote
Old 21st December 2010, 03:19 PM   #4
diyAudio Member
 
Join Date: Dec 2010
Hi Whaleman

I seem to have a similar problem. My lepai 2020 lost one channel after 2 days. What did you do with yours to solve the problem? How did you solve it?

Thanks

Gabio
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lepai T-Amp with TA2020 Fin Class D 1921 10th July 2014 05:25 AM
Lepai V3 with TDA8566 Electro-Chip Chip Amps 4 3rd January 2012 05:04 PM
Lepai TA2020 westsounds Class D 5 3rd January 2010 08:03 PM
Are these two Lepai amps actually the same? goodgnus Class D 4 14th October 2009 01:28 AM


New To Site? Need Help?

All times are GMT. The time now is 03:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2