TAS5630 damaged when touch the balance input op amp - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th August 2010, 09:32 AM   #1
diyAudio Member
 
Join Date: Jul 2010
Default TAS5630 damaged when touch the balance input op amp

hi all
i debug the class d amp with TAS5630,when i touch the balance input op amp ,it damaged ,anyone who have experienced ,why the sensitivity is so high ,and i don't know why it was damaged
__________________
impossible is nothing
  Reply With Quote
Old 4th August 2010, 12:39 PM   #2
81bas is offline 81bas  Germany
diyAudio Member
 
Join Date: Jan 2006
Location: Kiel
In my TAS5630 prototype I was able to touch anything without damaging the IC (PVDD 50V). Post your layout here, maybe it will be possible to find the reason then...
  Reply With Quote
Old 5th August 2010, 01:46 AM   #3
diyAudio Member
 
Join Date: Jul 2010
thank you for your reply 81bas,here's the pcb attached,i removed the swiching power which works well,it is high appreciated of your any thought ,ideas,proposal,advice..
Attached Files
File Type: zip TAS5630SE.zip (136.9 KB, 120 views)
__________________
impossible is nothing
  Reply With Quote
Old 6th August 2010, 08:57 PM   #4
81bas is offline 81bas  Germany
diyAudio Member
 
Join Date: Jan 2006
Location: Kiel
Hi!

I cannot open this "*.PCB" file I have tried it with eagle, pcad, sprint layout viewer, etc... Are you able to export it as PDF maybe? or simply as image?
  Reply With Quote
Old 13th August 2010, 01:30 PM   #5
Dimon74 is offline Dimon74  United States
diyAudio Member
 
Join Date: Feb 2008
To open file,use Protel or Altium designer
  Reply With Quote
Old 16th August 2010, 12:29 PM   #6
marce is offline marce  United Kingdom
diyAudio Member
 
Join Date: Jun 2007
Location: Blackburn, Lancs
Could be static discharge.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LME49880 JFET Input Op-Amp VLSI Solid State 14 3rd September 2014 05:32 PM
Why balance input for phono amp? Sunsun22 Analogue Source 37 1st December 2009 10:54 AM
About Op-Amp input range xiaonan Parts 8 24th October 2006 07:49 AM
Sonic Impact amp... Audio Input damaged... Godzilla Class D 2 20th October 2006 12:11 AM
Schematic For P.a With Op Amp Input zox2003 Solid State 19 10th March 2005 01:13 PM


New To Site? Need Help?

All times are GMT. The time now is 09:17 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2