diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   chip burn-out when plug-in or plug-out DVD signal lines (http://www.diyaudio.com/forums/class-d/170839-chip-burn-out-when-plug-plug-out-dvd-signal-lines.html)

xujing79 26th July 2010 05:45 AM

chip burn-out when plug-in or plug-out DVD signal lines
 
I've designed a class-d amplifier with one internal LDO. when I plug-in or plug-out DVD signal lines, the chip is ease to burn-out. if I add one zener(5.7V) between LDO output and ground, everything is ok. I don't know why this happen? please give me some suggestion to find this cause, thank you! Kenneth

m-tech 26th July 2010 12:13 PM

Too much capacitance on LDO output ?
Adding a diode from output to input can solve this problem.

xujing79 28th July 2010 11:46 AM

m-tech, thanks for your suggestion.
I've try your solution:
1) add 1 schottky diode between LDO output and Vin, it's improved, but finally it's also broken.
2) change LDO output capacitor from 1uF to 0.1uF, it's also improved, but it's also broken finally.
could you please explain your original idear in detail?
my design is high-power class-d audio amplifier. if add external schottky between output and gnd, and add 1 zener between LDO output and gnd, everything is ok. I'm not very clear about the root cause.

xujing79 3rd August 2010 05:07 AM

Hi, all,
I have more testing for this problem. when it occurs, ldo output will fly to 10V, and then it will latch to 3V(normal is 5V). I don't know what happene for the internal circuit. please give your experience, thank you!


All times are GMT. The time now is 02:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2