Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

ucd 25 watts to 1200 watts using 2 mosfets
ucd 25 watts to 1200 watts using 2 mosfets
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th November 2017, 06:19 PM   #4621
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
hi all

i am back with my issues about sigma delta irs900d .

i have tried to bridge two irs 900d without success , they always end up latching or producing noise and drawing alot of current.

i increased the output inductance to 120uh (it improved the situation but did did not help)

i added 80uh inductance to each power rail of each channel both +/- rails also (it improved the situation but did did not help)

the major issue ,is that when you disconnect the load from the amplifier the ,amp suddenly becomes unstable and draws alot of current like a short circuit , and the output fets heat up
  Reply With Quote
Old 8th November 2017, 06:54 PM   #4622
Dimonis is offline Dimonis  Russian Federation
diyAudio Member
 
Dimonis's Avatar
 
Join Date: Mar 2011
Location: RF 33 Vladimir
Quote:
Originally Posted by stewin View Post
the major issue ,is that when you disconnect the load from the amplifier the ,amp suddenly becomes unstable and draws alot of current like a short circuit , and the output fets heat up
Hi , show the exact schematics.
Unstable - it generates on the resonanse frequency of the output filter ?
  Reply With Quote
Old 8th November 2017, 08:29 PM   #4623
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Quote:
Originally Posted by Dimonis View Post
Hi , show the exact schematics.
Unstable - it generates on the resonanse frequency of the output filter ?
just the normal irs900d circuit by detex audio . output fets are irfp250 .supply voltage +/-38v
Attached Images
File Type: jpg ab722e449ca921e4.jpg (250.2 KB, 368 views)
File Type: jpg CHE-900D checking.jpg (143.9 KB, 367 views)
Attached Files
File Type: pdf irs 900d corect artwork print .pdf (351.5 KB, 101 views)
  Reply With Quote
Old 16th November 2017, 11:19 PM   #4624
protech1104 is offline protech1104  Tunisia
diyAudio Member
 
protech1104's Avatar
 
Join Date: Mar 2016
Location: sousse
Quote:
Originally Posted by stewin View Post
hi all

i am back with my issues about sigma delta irs900d .

i have tried to bridge two irs 900d without success , they always end up latching or producing noise and drawing alot of current.

i increased the output inductance to 120uh (it improved the situation but did did not help)

i added 80uh inductance to each power rail of each channel both +/- rails also (it improved the situation but did did not help)

the major issue ,is that when you disconnect the load from the amplifier the ,amp suddenly becomes unstable and draws alot of current like a short circuit , and the output fets heat up
in steréo mode your amplifier work good? if yes you must have a low pass filter at aop used for the bridge.
and dont run 2amplifier at same frequency
  Reply With Quote
Old 17th November 2017, 11:17 AM   #4625
kees52 is offline kees52  Netherlands
diyAudio Member
 
Join Date: May 2009
Location: Sprang-capelle Holland.
Quote:
Originally Posted by protech1104 View Post
in steréo mode your amplifier work good? if yes you must have a low pass filter at aop used for the bridge.
and dont run 2amplifier at same frequency
Did you use 180 degree shift? otherwise you get big trouble who looks a like as you already have explane.

regards
  Reply With Quote
Old 18th November 2017, 05:23 PM   #4626
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Quote:
Originally Posted by protech1104 View Post
in steréo mode your amplifier work good? if yes you must have a low pass filter at aop used for the bridge.
and dont run 2amplifier at same frequency
meaning one to be at 430khz and the other at 400khz ??
  Reply With Quote
Old 19th November 2017, 05:29 AM   #4627
KimeraTeam is offline KimeraTeam
diyAudio Member
 
Join Date: Jul 2016
how to change frequency to 250KhzClick the image to open in full size. suply +-50Vdc
  Reply With Quote
Old 28th November 2017, 07:19 PM   #4628
protech1104 is offline protech1104  Tunisia
diyAudio Member
 
protech1104's Avatar
 
Join Date: Mar 2016
Location: sousse
Quote:
Originally Posted by KimeraTeam View Post
how to change frequency to 250KhzClick the image to open in full size. suply +-50Vdc
this circuit is not stable. use apex d200 version is good and simple. and use external 12v supply for driver regulated for less heat supply transistor
  Reply With Quote
Old 28th November 2017, 07:22 PM   #4629
protech1104 is offline protech1104  Tunisia
diyAudio Member
 
protech1104's Avatar
 
Join Date: Mar 2016
Location: sousse
Quote:
Originally Posted by stewin View Post
meaning one to be at 430khz and the other at 400khz ??
yes. but also irs 900 is not stable. the best is apex d200 or macky srm450 is the same
  Reply With Quote
Old 28th November 2017, 07:24 PM   #4630
protech1104 is offline protech1104  Tunisia
diyAudio Member
 
protech1104's Avatar
 
Join Date: Mar 2016
Location: sousse
i have a d200 that work without problem for 5 years now
  Reply With Quote

Reply


ucd 25 watts to 1200 watts using 2 mosfetsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 96 4th August 2017 10:40 AM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 02:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 07:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 07:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 09:29 AM


New To Site? Need Help?

All times are GMT. The time now is 08:05 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki