ucd 25 watts to 1200 watts using 2 mosfets - Page 342 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D
Home Forums Rules Articles The diyAudio Store Gallery Blogs Donations FAQ Calendar Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
 
 
Thread Tools
Old 4th April 2013, 11:07 AM  
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Hi Exflaco
greetings totem is MPSA42 MPSA56 isnt mpsa 42 complementary to mpsa 92
warm regards
andrew lebon FULL FILES WILL BE SHARED
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
 
Old 4th April 2013, 06:28 PM  
diyAudio Member
 
Join Date: Dec 2003
Location: Munich
Quote:
Originally Posted by norazmi View Post
current rating its depend what type of mosfet you are using, 20-30 amp is enough.
...mostly true.
In classD the limitation often is not given by the current rating, but more by the switching losses and Rth of the MosFet.
Consequently a MosFet with good body diode and low Rth, but not impressive current rating, can easily outperform (also in terms of amp power) a stone age monster with poor body diode.
The higher your fs, the more this will apply.
 
Old 5th April 2013, 07:11 AM  
Banned
 
Join Date: Jan 2005
I've put together a "Universal Power Module (UPM) that supports both pre and post filter feedback, as well as clocked modulators.

Bottom layer: http://i.imgur.com/IRWpUxu.png
Top layer: http://i.imgur.com/rnssSzN.png

This is however just a preliminary layout that may change at any time.
 
Old 7th April 2013, 11:34 AM  
diyAudio Member
 
Join Date: Sep 2010
Location: Quezon City
Anyone tried CD4069 for comparator? I want to save space for the pcb so I'll gonna try it instead of CD4049
 
Old 7th April 2013, 11:39 AM  
Banned
 
Join Date: Jan 2005
There was once a class d amplifier posted in this section that only had 4000 series or 74 series logic ics in the frontend, the OP was named nitrate and the amp was called madamp and it was a basic delta sigma approach.

Last edited by Tekko; 7th April 2013 at 11:49 AM.
 
Old 7th April 2013, 06:48 PM  
diyAudio Member
 
Join Date: Oct 2009
Quote:
Originally Posted by manojtm View Post
Hi Stewin,

can you tell me the air gap of ETD49 and EE19. A=?? for 95V load

Regards
Manoj

Hi sweet,

I will give you the sprint layout file for AUD600 & Power AUD600

Regards
Manoj
Hi Manoj.
Please send me that file too.
luizcpimenta@gmail.com

Thank you.
 
Old 7th April 2013, 10:37 PM  
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
hi all i am making at least a supply to reach 2.5 kwt with o.c protection just about to finish . any ideas would be highly appreciated
 
Old 8th April 2013, 01:27 PM  
diyAudio Member
 
Join Date: Aug 2010
Quote:
Originally Posted by IRSound View Post
Hi guys..

so I've just finished IRS1500..but there is also a problem

please watch this video :

Class-D IRSD1K5 - No & Low Level input Problem - YouTube

when i turn on power supply..after s short delay , speaker connected to amp's out. as you can hear in video , there is a noise available at output. (input volume = 0) and when i increase volume up to 4~5%, a really bad audio signal become appear. also the active led indicator isn't bright constantly.
when i increase the volume (about 7~8 %) the amp start to oscillate and those problem solved.

guys please help me. anyone have similar problems ?

Regards,
IRSound

hi IRSound ,i know your problem ,

change you IC CD4049 with other manufacture

i have same problem like you
and result are ok change IC CD4049 with ST manufacture ,before TI manufacture.
my irs can work at minimal 15 volt supply with out change RSS (6,8k)

regards,

Reno
 
Old 8th April 2013, 06:50 PM  
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
to add on the above . i had problems with irs4k5 outputs were heating , once i changed the cd4049 . everything was o.k and outputs stopped heating.
 
Old 9th April 2013, 08:31 AM  
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Quote:
OP was named nitrate and the amp was called madamp
Hi Tekko,

Why you call madamp???

I think Delta-Sigma design was good one compare with other self oscillated design.
Low noise,No hum and clear sound.

Regards
MANOJ
 

 

Hide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 68 18th April 2015 07:23 PM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 01:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 06:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 06:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 08:29 AM


New To Site? Need Help?

All times are GMT. The time now is 02:07 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright ©1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2