Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th March 2013, 10:47 PM   #3331
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Class d can be touchy about starting up.

The 2092 class d chip sits with 17 volts dc on the output if no speaker is connected !
Once a speaker is connected it then works ok.

It looks like your circuit is starting to oscillate then stops hence the clicking.
I can see a decaying oscillation.
You need to look at the positive feedback that gives oscillation.
__________________
http://www.murtonpikesystems.co.uk PCBCAD50 pcb design software.
  Reply With Quote
Old 14th March 2013, 09:39 AM   #3332
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Quote:
Does the amp start to oscillatenn with low level input signal and the noise gone ?

I want to know is those problem solve now ?
Hi Nmos,

Level shifter not good,adjust the resistor value to get min. 1v and max. 3.3v signal with respect to -ve supply rail.

all sigma delta design freq. is depend on feedback resistor,filter coil,MOSFET,IC(TL071),2x1nF capacitor and 1K resistor.

Regards
MANOJ
  Reply With Quote
Old 14th March 2013, 04:21 PM   #3333
NMOS is offline NMOS  Germany
diyAudio Member
 
NMOS's Avatar
 
Join Date: Dec 2010
Location: Frankfurt
Quote:
Originally Posted by manojtm View Post
Hi Nmos,

Level shifter not good,adjust the resistor value to get min. 1v and max. 3.3v signal with respect to -ve supply rail.

all sigma delta design freq. is depend on feedback resistor,filter coil,MOSFET,IC(TL071),2x1nF capacitor and 1K resistor.

Regards
MANOJ
How about your AUD 600 Amp Rev 3.0

Does AUD 600 Amp amp have the same problem or is here the problem solved ?
  Reply With Quote
Old 15th March 2013, 06:17 AM   #3334
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Quote:
How about your AUD 600 Amp Rev 3.0

Does AUD 600 Amp amp have the same problem or is here the problem solved ?
Hi NMOS,

AUD600, no issues it will start at very low signal input and no noise low temp at full drive and good sound.

Regards
MANOJ
  Reply With Quote
Old 15th March 2013, 06:57 AM   #3335
diyAudio Member
 
Join Date: Sep 2010
Location: Quezon City
Hi Manoj,

Did you check the AUD600 for possible latch-on of high side output during power up and overstress condition?

You can test it by disconnecting any load in the amplifier, shorting the output and put an input signal. It will trigger the over current protection,

Let us see if the high side mosfet (or your amp) survives with continuous triggering of over current protection.
  Reply With Quote
Old 17th March 2013, 07:22 PM   #3336
PetruV is offline PetruV  Romania
diyAudio Member
 
Join Date: Dec 2012
Location: Bucuresti
Quote:
Originally Posted by andrewlebon View Post
small smps under construction trafos 2 heavy
Can you give some more info on that smps,i want to build one,but can you give me pcb and layout
__________________
I know everything but do nothing
  Reply With Quote
Old 20th March 2013, 12:30 AM   #3337
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
+40V 0v -40v / 10A SMPS For Power Amplifier post#9
Hi PetruV
greetings i have not finished the pcb layout as the core i am using is small for 130
volts dc+/- for my dclass amp if you are new to smps please make the smps from the link above i dont think there is a more EASY smps than this for first smps it can be made on
dot pcb i used IRF460 for fets 15 volts dc can be modified easier if you want so my sincere advice make this smps any help you need will be extended to you just start this smps
warm regards
andrew lebon
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 20th March 2013, 03:44 PM   #3338
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Hello
greetings whats the most powerful mosfets for d class pushed amp till 140 volts dc+/-
on 300 volt fets
warm regards
andrew lebon
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 21st March 2013, 06:07 AM   #3339
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Hi Andrew,

use IRFP23N50, not a powerful one but it can handle 140 DC

Regards
MANOJ
  Reply With Quote
Old 21st March 2013, 06:24 AM   #3340
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Hi Manoj
greetings already amp is playing on 140 volts dc +/-
i will post pics of working amp any more powerful fets with higher rails
warm regards
andrew lebon
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 55 4th April 2014 07:08 AM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 01:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 06:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 06:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 08:29 AM


New To Site? Need Help?

All times are GMT. The time now is 11:26 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2