ucd 25 watts to 1200 watts using 2 mosfets - Page 310 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th December 2012, 07:38 AM   #3091
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Quote:
Originally Posted by manojtm View Post
Hi All

IRS4K5

+95V,-95V 2 Ohms load only.max Current= 47A

then why we need a 3 pair MOSFET??? a single 75A 25 degree 100nC MOSFET will do 4K5 output.

My AUD600 with IRFP4668 gate resistor 39R / 47R with supply +90V -90V will do 4000W 2R load

Regards
MANOJ
Hi manoj i am about to finish and test your amp i will post photo and my review later.


Does it mean if you bridge aud600 with the right fets at 4ohms you will get an output of 8kwts ?
  Reply With Quote
Old 27th December 2012, 12:32 PM   #3092
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Default VIPER12A

Hi Irvynejay
greetings viper12a giving 60 volts dc no 15.5 volts smps is working i used top244 ic for 15 volts pls check
warm regards
andrew lebon
Attached Images
File Type: jpg 2500W SMPS.JPG (646.6 KB, 1079 views)
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 27th December 2012, 12:35 PM   #3093
diyAudio Member
 
irvynejay's Avatar
 
Join Date: Nov 2010
Location: Philippines;Mindanao,Butuan
Send a message via Yahoo to irvynejay Send a message via Skype™ to irvynejay
pls check mail to check faults
__________________
Knowing GOD is not being good,Knowing GOD is just knowing him as my friend
  Reply With Quote
Old 27th December 2012, 12:36 PM   #3094
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Default VIPER12A

still lots of work on pcb to be completed
warm regards
andrew lebon
Attached Images
File Type: jpg 2500W.JPG (833.5 KB, 957 views)
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 27th December 2012, 03:49 PM   #3095
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Hi manoj i just finished aud600 amp but it is not working ,it is emitting dc on outputs. I have cross checked the pcb

i used irfp250n for output fets , ic is sn74s04n my voltage is +/-48vlts and small adaptor 12volts 1.5amps . i did not make the power aud600 side i was eager to hear the amp . Thanking you in advance stewin

Last edited by stewin; 27th December 2012 at 04:07 PM.
  Reply With Quote
Old 27th December 2012, 05:33 PM   #3096
akraj is offline akraj  Bangladesh
diyAudio Member
 
Join Date: Nov 2010
Hi: Stewin, I also made this aud600 and soldering parts!

By the way which version you used?? As per hadi, version 1.0 worked.

hope to share my experience shortly.

Thanks
Raj
  Reply With Quote
Old 27th December 2012, 06:28 PM   #3097
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Quote:
Originally Posted by akraj View Post
Hi: Stewin, I also made this aud600 and soldering parts!

By the way which version you used?? As per hadi, version 1.0 worked.

hope to share my experience shortly.

Thanks
Raj
I think mine is ver1.1
  Reply With Quote
Old 28th December 2012, 12:29 AM   #3098
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Quote:
Originally Posted by stewin View Post
Hi manoj i just finished aud600 amp but it is not working ,it is emitting dc on outputs. I have cross checked the pcb

i used irfp250n for output fets , ic is sn74s04n my voltage is +/-48vlts and small adaptor 12volts 1.5amps . i did not make the power aud600 side i was eager to hear the amp . Thanking you in advance stewin

i am using aud600 ver1.1

is this ic the one causing my amp not to work? sn74s04n

by the way my output inductor is etd42 with 64turns . below the boards and the schema i used .

ucd 25 watts to 1200 watts using 2 mosfets
Attached Images
File Type: jpg SAM_0587.JPG (420.6 KB, 790 views)
  Reply With Quote
Old 28th December 2012, 05:07 AM   #3099
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Quote:
Hi manoj i just finished aud600 amp but it is not working ,it is emitting dc on outputs. I have cross checked the pcb

i used irfp250n for output fets , ic is sn74s04n my voltage is +/-48vlts and small adaptor 12volts 1.5amps . i did not make the power aud600 side i was eager to hear the amp . Thanking you in advance stewin
Hi stewin,

without Power board it will not work.you need miner changes to do then it will work without power board.

(a) BIAS (-) pin to -75V supply
(b) remove IN4148 from NE555 IC connected to PIN 11 of IR2110.(now OC will not work)
(c) +12V for BIAS supply with respect to -ve rail supply
(d) Provide DC Protect

My AUD600 rev1.0,1.1 & 1.2 all are working one

Regards
MANOJ
  Reply With Quote
Old 28th December 2012, 06:42 PM   #3100
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
hi to all i also made the 4k5 and tested it . it worked o.k perfectly .but i prefer irs900d in mids. but sound is o.k . i used irp250n one pair only , gate resistor is 100ohms, voltage is +/- 67.9 vlts the outputs are cold as ice and are not on mounted on any heatsink. my load is 12ohms speaker . inductor is 24turns ei core from old pc power supply.

what i noted is with large output inductor like 60uh both irs 900 and 4k5 the output fets get hot so about 20uh i found to work out o.k.


looks like i am very unlucky with aud600 still not working . i will try to change the 7404 and use cd4049 i suspect the ic has issues . and there is only one vendor with that part in my country . so i will try my luck with cd4049 .
of course i will change the pins

low quality pics . but better ones later
Attached Images
File Type: jpg Pic_1228_002.jpg (158.4 KB, 639 views)
File Type: jpg Pic_1228_003.jpg (155.2 KB, 542 views)
File Type: jpg Pic_1228_005.jpg (153.8 KB, 135 views)
File Type: jpg Pic_1228_006.jpg (280.7 KB, 164 views)
File Type: jpg Pic_1228_008.jpg (258.9 KB, 166 views)
File Type: jpg Pic_1228_009.jpg (276.4 KB, 147 views)
File Type: jpg Pic_1228_016.jpg (338.1 KB, 195 views)
File Type: jpg Pic_1228_021.jpg (324.7 KB, 199 views)
File Type: jpg Pic_1228_022.jpg (135.8 KB, 130 views)
File Type: jpg Pic_1228_026.jpg (161.8 KB, 89 views)

Last edited by stewin; 28th December 2012 at 06:51 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 64 28th July 2014 11:33 AM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 01:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 06:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 06:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 08:29 AM


New To Site? Need Help?

All times are GMT. The time now is 04:09 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2