ucd 25 watts to 1200 watts using 2 mosfets - Page 171 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th February 2012, 03:54 PM   #1701
CPX is offline CPX  Romania
diyAudio Member
 
Join Date: Nov 2004
Location: Cluj
Dzony988 ..you shoud have no bus pumping in bridge mode.

Unfortunately No One makes real tests..i asked several times for some distorsions tests in vain...

Also i am interesested how you have implemented your protection schemes..the amplifier has to survire a short to output or rails, also over power in hard clipping,excesive bus pumping at 10-20hz and very high currents(>20A) ...simply sensing peak currents is not enough.

Last edited by CPX; 29th February 2012 at 04:10 PM.
  Reply With Quote
Old 29th February 2012, 05:16 PM   #1702
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
hi cpx .what can be done to avoid bus pumping and the above?
  Reply With Quote
Old 29th February 2012, 05:34 PM   #1703
CPX is offline CPX  Romania
diyAudio Member
 
Join Date: Nov 2004
Location: Cluj
Alot can be done..and i am still doing experiments.

I have around 10-15 volts bus pumping at 20 hz so probably this in not the reason my fets burn at 25A,but reducing capacitance from 10mF to 5 mf makes them burn at only 8A rms,so bus pumping may not be the problem...increasing capacitance to 15mf and adding a high pass filter will probaly solve this...

Hard clipping is another story..when hard clipped before peak current the peak current protecion will not work since is not measuring rms.A rms to voltage should be used but the conversion is to slow for efective protection so i will try implement an aditional rms current protection.

Also a clipping current limitator can be implemented but that will not save the amplifier if it is fed with a square wave.
  Reply With Quote
Old 29th February 2012, 06:01 PM   #1704
Dimonis is offline Dimonis  Russian Federation
diyAudio Member
 
Dimonis's Avatar
 
Join Date: Mar 2011
Location: RF 33 Vladimir
Quote:
Originally Posted by Dzony988 View Post
Only problem with full bridge is very high current and bus punping.
You mean pumping ?
In full bridge there"s no bus pumping
  Reply With Quote
Old 29th February 2012, 06:08 PM   #1705
CPX is offline CPX  Romania
diyAudio Member
 
Join Date: Nov 2004
Location: Cluj
Quote:
Originally Posted by Dimonis View Post
You mean pumping ?
In full bridge there"s no bus pumping
It may be if the bridge is unbalanced by using different switching frequencies between amplifiers creating unequal gain,but should be negligible .. 1 or 2 volts.
  Reply With Quote
Old 29th February 2012, 06:40 PM   #1706
Dimonis is offline Dimonis  Russian Federation
diyAudio Member
 
Dimonis's Avatar
 
Join Date: Mar 2011
Location: RF 33 Vladimir
CPX
Agree with you.
But that"s not a good bridge
And i doubt about switching freq.
  Reply With Quote
Old 29th February 2012, 06:57 PM   #1707
CPX is offline CPX  Romania
diyAudio Member
 
Join Date: Nov 2004
Location: Cluj
Quote:
Originally Posted by Dimonis View Post
CPX
Agree with you.
But that"s not a good bridge
And i doubt about switching freq.
In mixed mode operation(stereo - bridge) you need to have different switching speeds and gains.
  Reply With Quote
Old 29th February 2012, 07:37 PM   #1708
Dimonis is offline Dimonis  Russian Federation
diyAudio Member
 
Dimonis's Avatar
 
Join Date: Mar 2011
Location: RF 33 Vladimir
Ok. I understood about switching frequences , but why must the gains differ?
  Reply With Quote
Old 29th February 2012, 07:42 PM   #1709
CPX is offline CPX  Romania
diyAudio Member
 
Join Date: Nov 2004
Location: Cluj
Different switching speeds generate diferences in gain also in this ucd..i was unable to change gain and switching frequency indepenend on each other.
  Reply With Quote
Old 1st March 2012, 06:54 AM   #1710
diyAudio Member
 
irvynejay's Avatar
 
Join Date: Nov 2010
Location: Philippines;Mindanao,Butuan
Send a message via Yahoo to irvynejay Send a message via Skype™ to irvynejay
Hello can i ask some newbie question could i use this mosfet on class d amp
IXFX30N100Q2 and IXFH15N80
__________________
Knowing GOD is not being good,Knowing GOD is just knowing him as my friend
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 64 28th July 2014 11:33 AM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 01:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 06:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 06:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 08:29 AM


New To Site? Need Help?

All times are GMT. The time now is 08:31 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2