UcD400 & SMPS400/67 voltage mismatch? - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th October 2009, 09:06 PM   #1
AIS is offline AIS
diyAudio Member
 
Join Date: Oct 2009
Default UcD400 & SMPS400/67 voltage mismatch?

What is it that I don’t understand??

The SMPS400/67 has a rated output of 2x67Vdc (nominal I presume). Think I read somewhere that it could actually reach 75V.

The input voltage for the UcD400 module is +/- 45-65V. OVP is actually set to 68V.

Somehow I get the feeling that these two puppies shouldn’t play all that well together… Obviously I’m wrong since the hypex homepage sais that the SMPS400/67 is for the UcD400 but could someone please explain why…
  Reply With Quote
Old 31st October 2009, 07:30 PM   #2
DavidT is offline DavidT  United States
diyAudio Member
 
Join Date: Sep 2005
Default New vs old power supply specs

AIA,

Ran into this also with my new build. As I read the mfg info :

UCD 400 Original Spec:

Range 45 - 63 V
Max 65 V
Shut down 68 V


UCD 400 New Spec:

Range 45 - 67 V
Max 75 V
Shut down 30 & 75 V



David
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with hypes ucd400 and Smps400 Phil Olson Class D 6 12th January 2010 07:08 AM
impedance mismatch ddoyle Multi-Way 6 17th January 2008 03:06 PM
Heater voltage mismatch m6tt Tubes / Valves 16 19th September 2007 02:06 AM
Impedance Mismatch sushizen Full Range 1 16th November 2006 12:18 PM
CT impedence mismatch? lpd Tubes / Valves 2 28th December 2004 01:34 AM


New To Site? Need Help?

All times are GMT. The time now is 08:57 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2