Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

Preamp -> Class-D = Noise
Preamp -> Class-D = Noise
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th September 2009, 04:38 PM   #1
Cyberzim is offline Cyberzim  Denmark
diyAudio Member
 
Join Date: Apr 2009
Default Preamp -> Class-D = Noise

Hi there,
I have succesfully made a tpa3122 class-d amp on a breadboard.
It plays pretty loud, but not loud enough, and I have measured it to only being 5watt with 25V, and according to the datasheets I can get more.
So I made a preamp with a TL072, that have a gain of 1.
But when I connect the output from the preamp to the amp, it just start making a lot of noise.
What's the problem?

Thank you,

Simon H.A.
  Reply With Quote
Old 24th September 2009, 05:06 PM   #2
marchel is offline marchel
diyAudio Member
 
Join Date: Nov 2007
Have you connected the pre to another amp and do you still get noise?
  Reply With Quote
Old 24th September 2009, 05:27 PM   #3
Cyberzim is offline Cyberzim  Denmark
diyAudio Member
 
Join Date: Apr 2009
The opamp didn't work, but I found a LM358 opamp, an it works, but as soon as I add gain to the opamp it goes nuts.
  Reply With Quote
Old 24th September 2009, 05:35 PM   #4
Cyberzim is offline Cyberzim  Denmark
diyAudio Member
 
Join Date: Apr 2009
NVM, it works now, I just think it's because the amp is sometimes unstables because it's on a breadboard.

Thanks for help anyway,

Simon H.A.
  Reply With Quote

Reply


Preamp -> Class-D = NoiseHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hum to noise problem with class A chipamp ionomolo Chip Amps 5 2nd June 2008 04:48 PM
Noise troubleshooting Class D Tom7227 Class D 10 4th December 2007 08:22 PM
what causes noise in a SS preamp? woodturner-fran Solid State 5 27th May 2007 11:33 AM
Noise problems in non discrete class-d amp Baldin Class D 26 18th February 2007 09:00 AM


New To Site? Need Help?

All times are GMT. The time now is 03:17 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki