MTX 6500D with problems - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th September 2009, 05:36 PM   #1
diyAudio Member
 
Join Date: Sep 2009
Default MTX 6500D with problems

So this is what I'm working with. I originally used this amp for a year and one day it quit. Then it would power up and play for 5 or so seconds and then quit again. So I put the board on my bench. Hooked to an o-scope, put in a signal and noticed that it would still only output for 5 seconds then output went dead. The power supply was still pulling about 1.5 amps, so I think it is functioning correctly.

So I pulled the board out and resoldered all joints that looked like they got hot. I then powered the amp up and had no output. Left it on for about 10 minutes and it started to work. Left it on for about 20 minutes and my output died along with my LED (first time led shut off). Now my output has 60V on it continuous and amp is pulling 14 amps continuous. I'm guessing I fried the output FETS. ordered new ones. Anything else that could cause this problem while I wait for FETS to ship?

Thanks!
Kyle
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MTX 6500D - No Output Pioneer621 Car Audio 113 28th May 2013 11:26 PM
MTX 6500d Parts weston_sagle Car Audio 19 21st September 2010 08:44 PM
MTX 6500D Repair Rasputin713 Car Audio 1 2nd September 2009 04:26 AM
MTX Thunder 6500D burnt ifrythings Car Audio 10 18th April 2008 05:35 AM
MTX 6500D repair bil Car Audio 3 29th May 2006 06:19 AM


New To Site? Need Help?

All times are GMT. The time now is 08:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2