Hifonics Bxi 1606d Please Help - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th July 2009, 04:46 AM   #1
dmeche is offline dmeche  United States
diyAudio Member
 
Join Date: Jul 2009
Unhappy Hifonics Bxi 1606d Please Help

I HAVE A BXI HIFONICS 1606 D AMP. ONE DAY IT JUST STOPPED WORKING. THE HIFONICS LOGO ILLUMINATES WHEN I TURN IT ON BUT THERE IS NO SOUND OUTPUT. PLEASE PLEASE HELP
  Reply With Quote
Old 24th July 2009, 11:09 PM   #2
dmeche is offline dmeche  United States
diyAudio Member
 
Join Date: Jul 2009
Default i am just adding more info

i just wanted to add that the amp is getting power because the logo illuminates but yet neither the power led nor the protection led or on. thanks and please help anyone who can
  Reply With Quote
Old 25th July 2009, 04:14 PM   #3
judtoff is offline judtoff  Canada
diyAudio Member
 
Join Date: Jul 2005
Location: Goderich
Is it still under warranty?
If not open the cover and see if you can find anything wrong with it.
  Reply With Quote
Old 25th July 2009, 08:15 PM   #4
dmeche is offline dmeche  United States
diyAudio Member
 
Join Date: Jul 2009
no its not under waranty anymore...but i opened the back and there is nothing visually wrong with it...nothing looks burnt or broken
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hifonics BXi 1606D burnt resistors??? gadgeteer123 Class D 7 30th June 2009 09:55 PM
Sub for Gen VII HiFonics Morts Car Audio 0 26th May 2009 05:29 PM
Hifonics Problem swordfish689 Car Audio 5 2nd April 2007 04:49 PM
Hifonics Zeus VII redimp Car Audio 1 20th December 2006 11:47 PM
Hifonics Cupid Lasse- Car Audio 3 5th February 2004 11:28 PM


New To Site? Need Help?

All times are GMT. The time now is 01:05 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2