LANEY B1 Amp - Blown outputs - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th April 2009, 07:42 PM   #1
diyAudio Member
 
Join Date: Apr 2009
Default LANEY B1 Amp - Blown outputs

HI:

This is my first post to the forum. I am repairing this amp which is using the Tripath TA0104 preamp chip. The output transistors are STW38NB20's (W38NB20) . I have found a supplier with the transistors in stock. At least one is shorted from what looks like a liquid spill near the heatsink where they mount onto.

When powered up, and input signal applied, I can see the LED-VU levels bounce on both the input and output monitoring. There is a green LED near the tripath chip which is not lit, labeled 'run'. Does this mean the Tripath chip is not running and ought to be replaced? I have read about some replacements for this chip which are inconclusive. Ought I just replace it, or is the run light a sign its bad? Nothing else seems burnt, but there are 2 black color hi-watt resistors that dont seem to have any resistance at all, and may be open, but I need to remove them from the board to be sure. They are shown in the photo below each channels power transistors. Thanks.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Laney HCM160B's transistor zvir Solid State 2 16th February 2009 10:23 PM
Laney PA amp help! DoomPixie Tubes / Valves 15 28th November 2005 08:18 PM
laney PA amp questions DoomPixie Tubes / Valves 3 8th September 2005 04:57 PM
laney VC50 tuneman Instruments and Amps 0 19th July 2004 10:49 AM
need schematic for laney amp pedalboard jimminy Instruments and Amps 11 27th August 2003 11:12 PM


New To Site? Need Help?

All times are GMT. The time now is 12:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2