catastrophic error in UcD700HG supplied connection diagram - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th April 2009, 04:14 AM   #1
lwr is offline lwr  United States
diyAudio Member
 
Join Date: Oct 2003
Location: Charlotte, NC
Default catastrophic error in UcD700HG supplied connection diagram

I recently recieved a pair of UcD700HG modules with HxR along with the UcD700 supply, and TR700. The quality of the boards, parts, and layout are excellent, but the connection diagram supplied with the amp module has a catastrophic error.

Although the 14 page installation manual has full color photos of the current product, unfortunately the connection diagram has not been updated, and I did not discover the error until it resulted in dammage to the fist unit I assembled and tested.

I have copied and carefully edited the connection diagram (attached) to now show both the one that is correct for what I call "UcD700HG modules prior to Nov2007" and the current "Nov2007 UcD700HG modules." In a side by side comparrison you can see the differences between the boards that the Hypex proof-reader (and I) missed.

I have tried to call Hypex but have not been able to get through. I'm sending them an email about this, but I thought I had better post this on diyAudio too, in the hopes that anyone else that has recently recieved UcD700HD modules will be forewarned not to use the connection diagram that comes with them.

I'll let you know how the warranty repair works out for me.

lwr
Attached Images
File Type: jpg 2 edited diagrams.jpg (85.5 KB, 696 views)
  Reply With Quote
Old 8th April 2009, 09:11 AM   #2
Jorrit is offline Jorrit  Netherlands
diyAudio Member
 
Join Date: Aug 2004
Location: Netherlands
Hi lwr,

Thank you for notifying us about this error. We did discover this error a while ago and corrected it immediately.
Customers that have damaged their amplifier due to this error will have it replaced or repaired as quickly as possible. The labels on the board itself have always been correct.

We have always been very easy to reach by phone. It may have been the time difference.

Jorrit
Hypex Electronics
  Reply With Quote
Old 8th April 2009, 09:54 AM   #3
thedawg is offline thedawg  United States
diyAudio Member
 
Join Date: Mar 2009
So you get old date instruction with new date module, or you follow new date instruction from site with old date module? Does instruction in the box not same? Board still screen printed, should have seen
  Reply With Quote
Old 8th April 2009, 11:15 PM   #4
lwr is offline lwr  United States
diyAudio Member
 
Join Date: Oct 2003
Location: Charlotte, NC
Hi Dawg,

I received the old date instruction with new date module. Apparently Hypex is aware of the problem and has corrected the connection diagrams to match the new date modules. I was just unlucky enough to have gotten mine before the correction was made.

In over 45 years of buying boards, parts, upgrade modules, and kits, I have never seen such superior quality as what I have received from Hypex. In fact, I was so impressed that I didn't do the reconciliation of the board layout with the connection diagram that I have always done with everybody else.

What can I say? Even though I was taken in by Murphy's Law, I'm not too embarrassed by the incident. If I had made such a mistake with one of the Heath scope kits or OCSL boards of the bygone era - now THAT would be embarassing.

In the future I WILL reconcile the board layout with the connection diagram on Hypex products, but even so it will by no means be with the trepidation that it is totally justified to have with most other vendors.

I'll let you know how the warranty repair works out.

lwr
  Reply With Quote
Old 13th April 2009, 10:56 PM   #5
dallas is offline dallas  United States
diyAudio Member
 
Join Date: Sep 2007
I just ordered the exact same thing from Hypex. I will double check to make sure I have the correct information on the instructions. Good tip!
I was wondering if there is a compromise by using two of the 700HG modules with the single power supply and transformer?
Sorry if this has been covered before.
Thanks
Dallas
  Reply With Quote
Old 11th May 2009, 05:22 PM   #6
dallas is offline dallas  United States
diyAudio Member
 
Join Date: Sep 2007
We got the amp running it is using 2 of the 700HG HRX modules.
We did have to change some jumpers on modules. To allow for 2 modules on one power supply.
The sound is like no amp at all,but really high levels! Hard to imagine any better. What is better?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need connection diagram for Planet Audio HVT754 patife Car Audio 2 20th April 2007 12:43 PM
Connection Diagram for ESX 600.5 JoergST Car Audio 0 31st August 2006 08:32 PM
Hello, please need Connection Diagram Eyebrid 4Y80 JoergST Car Audio 1 18th July 2006 05:34 PM
Need Connection diagram for Alpine 3566 JoergST Car Audio 3 7th July 2006 10:10 AM
Possible error in Aleph 5 diagram!? hifi Pass Labs 2 11th April 2001 10:04 PM


New To Site? Need Help?

All times are GMT. The time now is 12:46 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2