about hip4080a,burned - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd April 2009, 06:41 AM   #1
diyAudio Member
 
Join Date: Feb 2009
Angry about hip4080a,burned

when i used 20V on the mosfet,and 12V on the IC HIP4080a,the ic was burned,i used the signal generater for the input of the IC,
i didn't know that why?
Attached Files
File Type: pdf dpa-1kwb.pdf (88.7 KB, 402 views)
  Reply With Quote
Old 3rd April 2009, 02:06 PM   #2
diyAudio Member
 
Join Date: Feb 2009
anybody help me,please!!!
  Reply With Quote
Old 3rd April 2009, 02:39 PM   #3
diyAudio Member
 
Whortless's Avatar
 
Join Date: Nov 2005
Location: Kocaeli,Turkey
Dear Freebird888,

I do not have much time to answer you. But, I saw that in your circuit the C7+R10, I would suggest that you to short circuit the C7. Also check the mosfets they must be burned and causing to your IC to burn. Also if you are using a signal generator for triangle make sure that the siganl level is in the input range of comp input of 4080.

regards
  Reply With Quote
Old 4th April 2009, 03:19 AM   #4
diyAudio Member
 
Join Date: Feb 2009
Thinks Whortless
In fact i short the C7 ,and I am sure the input signal is correct,
i found the wave of the gate of the mosfet.used the oscillograph,and i found the wave was very random,then i think the pin of the mosfet is too long,so i cut the pin more shorter,but the wave was also very random,i didn't know that why?
  Reply With Quote
Old 4th April 2009, 04:10 AM   #5
diyAudio Member
 
Join Date: Feb 2009
the wave of the gate:
Attached Images
File Type: jpg 100_1343.jpg (90.3 KB, 230 views)
  Reply With Quote
Old 4th April 2009, 10:38 AM   #6
diyAudio Member
 
Whortless's Avatar
 
Join Date: Nov 2005
Location: Kocaeli,Turkey
Freebird,

you showed only one of the gate and there are 3 left! But, according to my experience there is a problem in your PCB layout. I suggest you to center the 4080IC on mosfet arrays. It should be on the center of all 4 mosfets. So you can achive best and equal distance. I also suggest you to use slowly enable the IC by using simple C+R solution as in my shematic. I am sure that you can not correctly drive the comp of 4080 ic. Also make a blank test only with the audio signals and measure the comp out of IC without enabling the mosfet driver( use disable pin). And please upload some photos to make your thread attractive and to let someone to help you.

regards
  Reply With Quote
Old 4th April 2009, 12:02 PM   #7
diyAudio Member
 
Join Date: Feb 2009
Thank you very much,I will layout the pcb again
  Reply With Quote
Old 21st May 2009, 01:33 PM   #8
diyAudio Member
 
Join Date: Feb 2009
I had solved it,Power supply decoupling is very important,a excellent pcb layout and a good capacitance choosed for Power supply decoupling can reduced the peak of the mosfet'gata,and if the peak is above 95V,the IC or hip4080a will be damaged by the peak voltage.
Thanks!
  Reply With Quote
Old 22nd May 2009, 08:22 PM   #9
diyAudio Member
 
Whortless's Avatar
 
Join Date: Nov 2005
Location: Kocaeli,Turkey
Hi,

Will you post the working version of your circut?
  Reply With Quote
Old 23rd May 2009, 01:27 PM   #10
diyAudio Member
 
Join Date: Feb 2009
yes,I will post the working version,please wait some days
thinks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP Aleph 5 is burned? zigo3 Pass Labs 5 20th February 2008 01:00 PM
Burned T-amp fixable? jaste Class D 1 8th November 2007 09:38 PM
Burned capacitor slowpogo Parts 4 6th April 2007 05:29 AM
HIP4080A pspice model Anthony C Smith Class D 1 3rd January 2006 08:52 PM
UcD400 vs HIP4080a Thoughts? Mike2 Class D 4 17th March 2005 03:27 AM


New To Site? Need Help?

All times are GMT. The time now is 11:21 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2