HELP needed!! - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd March 2009, 04:44 PM   #1
diyAudio Member
 
Join Date: Feb 2009
Default HELP needed!!

hi i have been getting some help from this site on my alpine MRD-M605 mono amp mostly with 'perry babin' he suggested asking in this forum as someone may know further detail here is the link to the thread so far! hope you guys can help out a bit

http://www.diyaudio.com/forums/showt...08#post1761308

thanks to all that can help
  Reply With Quote
Old 3rd March 2009, 06:11 PM   #2
diyAudio Member
 
Join Date: Feb 2009
this is strange now it is displaying CUR again it did this before it gave up when installed in the car all voltages have dropped to below 0.20 v accross the board,i take it this is a safety feature?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed ! Inter M R300 schematics needed ! alexclaire Solid State 30 9th September 2009 07:14 AM
LT1964-adj Help Needed or Part Needed lgreen Parts 2 29th June 2007 03:50 PM
PSU Help Needed ardo Power Supplies 4 26th June 2006 06:15 PM


New To Site? Need Help?

All times are GMT. The time now is 10:29 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2