Sonic Impact T-amp loses one channel - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th February 2009, 06:21 PM   #1
jives11 is offline jives11  Europe
diyAudio Member
 
jives11's Avatar
 
Join Date: Mar 2004
Location: Hampshire
Default Sonic Impact T-amp loses one channel

Hi, I have a couple of the st gen T amps, but one keeps losing one channel. I don't think it's the 3.5mm signal, though I can see how these might fail if knocked. Sometimes powering off and on brings the channel back, but then it fails again sometime after.

Anyone else seen this problem ?
  Reply With Quote
Old 13th February 2009, 06:24 PM   #2
DcibeL is offline DcibeL  Canada
diyAudio Member
 
DcibeL's Avatar
 
Join Date: May 2003
Location: Saskatchewan
Do you own a multimeter?
__________________
The power of Science compels you!
  Reply With Quote
Old 13th February 2009, 06:46 PM   #3
diyAudio Member
 
Saturnus's Avatar
 
Join Date: Jun 2005
Location: Copenhagen, Denmark
I'm almost certain it's the jack ... either the plug or the socket. Those are notoriously bad quality.
  Reply With Quote
Old 13th February 2009, 07:01 PM   #4
DcibeL is offline DcibeL  Canada
diyAudio Member
 
DcibeL's Avatar
 
Join Date: May 2003
Location: Saskatchewan
If the jack is at fault it will be easy to test just by wiggling the connection.
__________________
The power of Science compels you!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
T-amp loses one channel, power off/on resets ? jives11 Class D 1 26th December 2008 05:51 PM
Sonic Impact T-amp - channel gone missing lampman Class D 11 26th March 2007 04:52 PM
Sonic impact t amp - supply voltage on the output of one channel deiksac Class D 6 7th April 2006 11:07 AM
Sonic Impact Bridge to single channel? zapwizard Class D 6 9th March 2006 04:59 PM
bi-amping with sonic impact t amp/using sonic impact amp for headphones jon_m Class D 3 16th February 2006 11:16 AM


New To Site? Need Help?

All times are GMT. The time now is 08:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2