Do I still need a fuse? - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 6th February 2009, 09:23 AM   #1
diyAudio Member
Join Date: Jan 2005
Location: Hawaii
Default Do I still need a fuse?

I'm using the Hypex SoftStart. Do I still need a fuse between the mains and the SoftStart or does the SoftStart make a fuse redundant?

Thanks in advance.
  Reply With Quote
Old 6th February 2009, 09:32 AM   #2
diyAudio Member
Saturnus's Avatar
Join Date: Jun 2005
Location: Copenhagen, Denmark
A fuse is mandatory for your own safety should anything go wrong. DO NOT under any circumstances leave it out.
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 11:39 AM
SMD Fuse stef1777 Parts 2 26th April 2007 01:03 AM
Why main fuse and not rail fuse? digital desire Solid State 10 3rd December 2006 09:07 PM
amp rating for fuse and fuse holder? riotubes Parts 5 27th August 2006 04:10 AM

New To Site? Need Help?

All times are GMT. The time now is 11:45 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2