Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd February 2009, 02:09 PM   #1
diyAudio Member
 
Join Date: Jan 2005
Location: Hawaii
Default Fuse question for ucd400

When using the Hypex SoftStart with two Hypex TR501a transformers for monoblock UcD400s, I assume the "mains" connection to the SoftStart should be FUSED. If so, what fuse rating should I use between the IEC and the SoftStart? Also, should it be slow blow or fast blow?

Sorry for the rookie questions, but got to start somewhere!

Thanks in advance.
  Reply With Quote
Old 3rd February 2009, 01:49 AM   #2
diyAudio Member
 
Join Date: Jan 2005
Location: Hawaii
I found my answer.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UCD400 Power supply question... ptwining Class D 1 15th January 2007 05:29 AM
UCD400 input question... ptwining Class D 8 24th October 2006 12:23 AM
fuse question v1d9uy Parts 3 8th May 2006 09:05 PM
Fuse question??? offroadbum Car Audio 8 26th October 2004 06:39 PM
fuse question JAZZ2250 Parts 6 14th September 2002 10:52 PM


New To Site? Need Help?

All times are GMT. The time now is 05:16 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2