Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th October 2008, 06:48 AM   #1
diyAudio Member
 
Join Date: Sep 2008
Default Behringer Pmx660m Power Amp Help

Hi everybody! Please i need help of yours. Ill appreciate you colaboration. Sory my english is nt good. Ive a PMX660M powered mixer, the power supply and power amp has failed, i suuspect of a mains fail (in the power supply, caps and transistors are blown, in the power amp, one of two channel blown the MOSFET and resistances). Has been repaired and operational, but:

When load is connected, the FBQ leds blinking without control, and the power amp is shutdown before to reach the maxium level output. While happen this, just before shutdown, the audio is distorted, generating audible "peaks" in the speakers. In the oscilloscope, i see the peak, the signal raises instantly to +V. Below of this peaks, the audio is perfecly clear and no distortion.

Two things: 1) when the mixer section is powered by another external power supply, the FBQ led are steady ok or working well.
2) ive tested with main and monitor output to load other amp and work ok without problems. For this im discarted the mixer section for this problem.

I have, tanks to this wonderful forum, the complete schematics of the circuits (SPS400 power supply and DPA300 power amp) , but i need help, im checking the components and all are ok. Only the main IC on the power amp (HCA4001) is not tested yet, but, all voltages in this are nominal.

What can be this problem? SOmebody has experienced with this modules?

Im very appreciate you help!

Regards for everyone from Argentina!


Gabriel.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Behringer A500 power amp problem, please help? emperor Solid State 36 20th January 2013 01:30 PM
FT: Behringer EP-2500 Power amp saabracer23 Swap Meet 0 25th March 2008 12:39 AM
Behringer MX9000 - odd power issue Deekaph Power Supplies 23 11th March 2008 04:16 PM
behringer dcx2496 buzzing from power inverter zbomb5610 Digital Line Level 2 27th March 2004 02:25 AM


New To Site? Need Help?

All times are GMT. The time now is 05:00 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2