Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st January 2008, 08:24 PM   #1
diyAudio Member
 
Join Date: Aug 2002
Location: Suffolk ,England
Unhappy T Amp problem, please help

Hi guys just wondering if anyone can shine a light on what might be wrong with my Autocostriuire T100HC board, i used to have it in a dedicated box, with a toroidal transformer, with a switch and it worked brill. in the meantime i bought an SMPS power suply and rigged it all up and it worked excellently. Problem is now that when i put it in the new box, with the SMPS, with a power switch, all set up correctly, the left channel, is nearly quiet, and the right normal.

I made the enclosure myself, and it has mdf sides bottom and top, but the two ends where the power switch, and the back where all the fittings, RCA, IEC sicket etc go are on an aluminium plate, covered in vinyl, like fablon. I didint think i needed the chassis ground as i thought none of the box would be conductive, have i shorted something, and ruined my amp. heres a pic..of the enclosure. where the drilled holes are, i have put some of the plastic coated vinyl in a strip.

[img=http://img112.imageshack.us/img112/9223/p1040551xn0.th.jpg]

any ideas input, insults accepted, all i know is at one point ive been a bit of an ****, and ruined something, hopefully it can be fixed?

thanks
  Reply With Quote
Old 1st January 2008, 11:45 PM   #2
diyAudio Member
 
Join Date: Aug 2002
Location: Suffolk ,England
No worries. i found the problem, on the RCA the pos and negative ground had been joined together with solder causing it to short, couldnt really see that until I looked closer. Phew, im relieved
  Reply With Quote
Old 9th January 2008, 11:53 AM   #3
muygar is offline muygar  Turkey
diyAudio Member
 
Join Date: Apr 2005
Location: istanbul
Send a message via ICQ to muygar
Emperor,I'm planning to use toroidal transformer for my tripath 2020 amp(charlize2) instead of SMPS.As a user of both what's the downside of toroids to SMPS for tripath amps.Thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mtx amp problem [[help!!]] fuzzypinkhat45 Car Audio 3 8th July 2008 05:34 AM
CDM 2/29 Problem HELP! Bassivus Digital Source 29 23rd December 2007 10:00 AM
FRD/ZMA Problem Twisted85 Multi-Way 5 4th December 2006 01:19 PM
p3a problem MaXiZ Solid State 17 16th July 2005 07:14 AM


New To Site? Need Help?

All times are GMT. The time now is 02:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2