Trends Audio TA-10 Questions - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd December 2007, 07:44 PM   #1
diyAudio Member
 
Join Date: Mar 2005
Location: Lexington, KY
Default Trends Audio TA-10 Questions

I just received my new TA-10 from Audio Magus and now I have a few questions.

My setup is a 5.5 gen iPod in dock to TA-10 driving Klipsch RB-25 bookshelf speakers (94dB sensitivity).

-When I turn the amp on, I hear a slight click in the left channel immediately followed by the same click in the right channel, is this normal?

-If I have no source connected and turn the amp volume all the way up, I hear the noise floor of the amp though it is louder through the left channel than the right. Is this indicative of something? I have also noticed that I have to turn the amp to at least 8 o'clock to get it to drive my speakers (when all the way down is 7) and at that volume, I get drive from the left channel but not the right, though maybe that's from the pot?

-The RCA inputs were discolored right out of the box. Does this matter or should I go ahead and plan on using better hardware connectors?

Thanks in advance for the help/advice/input!
  Reply With Quote
Old 22nd December 2007, 09:54 PM   #2
diyAudio Member
 
Join Date: May 2006
"-The RCA inputs were discolored right out of the box. Does this matter or should I go ahead and plan on using better hardware connectors?"

Check the connections on the inside at the RCA's, and all over in there. Good luck, it's too bad you are having problems. See how it looks inside, maybe you will find a problem?

Happy Holiday's! Good luck
  Reply With Quote
Old 22nd December 2007, 10:26 PM   #3
jimbo51 is offline jimbo51  Australia
diyAudio Member
 
jimbo51's Avatar
 
Join Date: Nov 2007
Location: Melbourne
Read section 4 of the Trends manual re adjusting DC bias voltage. It is possibly relevant to your issues.

Worth checking it initially and then after the "burn-in" period, say 20 - 50 hours.

Good Luck.
  Reply With Quote
Old 22nd December 2007, 11:12 PM   #4
diyAudio Member
 
Join Date: May 2006
Great point jimbo51, After 100 hours on my Trends 10.1, I adjusted the DC bias. It made a huge difference in the sound!
  Reply With Quote
Old 23rd December 2007, 10:21 AM   #5
bjengi is offline bjengi  Sweden
diyAudio Member
 
Join Date: Jun 2004
Location: Sweden
Tripath07, how did you and where do you measure?
  Reply With Quote
Old 23rd December 2007, 09:11 PM   #6
jimbo51 is offline jimbo51  Australia
diyAudio Member
 
jimbo51's Avatar
 
Join Date: Nov 2007
Location: Melbourne
Quote:
Originally posted by bjengi
Tripath07, how did you and where do you measure?

Bjengi,

Per the Trends Audio manual ......

4. Advanced Features (for professional user only)

4.1 Offset the DC bias voltage of the speaker terminals
There are two blue adjustable potentiometers (Rt) for offsetting the DC bias voltage between the positive (+ve) and negative (-ve) terminals of each channel. Offset this DC bias voltage can enhance the purity of the sound and minimize the “pop" sound when power on and off. The DC bias has been pre-set in factory. But after run-in for a period, it would be slightly changed that the fine-tuning is needed.

Before you tune these, you need a screwdriver (take off the case), a small screwdriver (turn the screw of the potentiometer) and a (digital) multi-meter to detect the DC bias voltage.

1. Use screwdriver to take out the two top level screws in the front panel & another two screws in the back panel. Then, open the upper case.
2. Power ON the amplifier..
3. Use the multi-meter to detect the DC voltage (200mV) between +ve & -ve terminals of the RIGHT channel.
4, Turn the screw on the top of the LEFT (near the front panel) potentiometer by a small screwdriver clockwise or anticlockwise until the voltage as close as to ±0mV.
5. Then, repeat step 3 and 4 for the LEFT channel by turning the screw on the top of the RIGHT (near the back panel) potentiometer.
6. Power OFF the amplifier
7. Cover back the upper case and tighten the screws.


Good Luck,

Jim
  Reply With Quote
Old 23rd December 2007, 09:23 PM   #7
diyAudio Member
 
Join Date: Mar 2005
Location: Lexington, KY
So, are my speaker pops normal? What about the unbalanced channels? Someone who owns one care to pipe up?
  Reply With Quote
Old 24th December 2007, 01:53 AM   #8
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Milliways
Blog Entries: 4
Default Re: Trends Audio TA-10 Questions

Quote:
Originally posted by echomancer
-When I turn the amp on, I hear a slight click in the left channel immediately followed by the same click in the right channel, is this normal?
Yes, this is normal, tho usually the click occurs at the same time in each channel. The click is the input caps charging up.

Adjusting the DC offset can lower the click a little, but will not eliminate it. Some voltmeters do not read the offset voltage very well, so beware. With all the Trends amps I've seen, the offset was only slightly off on one channel of one amp. So no need to worry, just check it.

Quote:
-If I have no source connected and turn the amp volume all the way up, I hear the noise floor of the amp though it is louder through the left channel than the right. Is this indicative of something?
Not much. Short out the inputs, or put a 100 ohm resistor across them. Got noise now? Open inputs are susceptible to noise, that's all.

Quote:
I have also noticed that I have to turn the amp to at least 8 o'clock to get it to drive my speakers
With the low output of an iPod, the volume should be somewhere near 3 o'clock - I would think. The pot in the Trends is not of the highest quality and part of that lack is that it does not track well. I.E., the channels are not perfectly matched. This will be especially noticeable right at the beginning of the wiper travel. Live with it, or replace or bypass the pot. It is likely much less a problem near 12 o'clock and above.

Quote:
-The RCA inputs were discolored right out of the box. Does this matter or should I go ahead and plan on using better hardware connectors?
Again, not the best quality. They are one of the first things to replace. Clean them up as best you can, then replace them with better. It's easy to do.

Hope that helps.
__________________
Take the Speaker Voltage Test!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trends Audio 10.1 resistors Chilli6565 Chip Amps 0 12th May 2008 02:26 AM
FT: Trends Audio TA-10 marginwalker Swap Meet 9 8th August 2007 05:04 PM
Trends Audio DAC Supply ecodoppler Digital Source 0 2nd July 2007 04:52 PM
Charlize vs Trends Audio TA-10? raver Class D 30 10th June 2007 04:14 AM
SB3 as Preamp with Trends Audio 10.1 Shiznit Digital Source 0 20th May 2007 07:29 PM


New To Site? Need Help?

All times are GMT. The time now is 03:03 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2