diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   Has anybody else had trouble contacting Coldamp...? (http://www.diyaudio.com/forums/class-d/108847-has-anybody-else-had-trouble-contacting-coldamp.html)

ptwining 21st September 2007 04:46 PM

Has anybody else had trouble contacting Coldamp...?
 
Has anybody else had trouble contacting Coldamp...?

I have emailed them twice (their contact form doesn't work) and have heard nothing back.

Just curious if they are having troubles or if they are still doing business.

Thanks,
Tom

BWRX 21st September 2007 05:21 PM

They're still doing business. You could try sending ssanmor (his real name is Sergio) an email through the forum.

ptwining 21st September 2007 05:57 PM

Coldamp...
 
I'll do that.

I have prototypes waiting for the SPS80 .

Just as an aside does anyone have any experience with the Coldamp supplies and the UCD 400's?

Thanks,
Tom

ptwining 21st September 2007 08:06 PM

Coldamp update... (Thank you BWRX)
 
I received an excellent email from Coldamp in which they answered all my questions and worked well to meet my needs.

My first email was lost as spam and they did a great job responding to my secondary queries.

Thanks to my fellow forum members and good job Coldamp!

Regards,
Tom

kristleifur 21st September 2007 11:05 PM

I'd like to state for the record that they were both quick to reply and pleasant about things when I emailed them about their SMPS, even though their power supply was regrettably too expensive for me. Very trustworthy seeming people.


All times are GMT. The time now is 09:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2