Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Chip Amps Amplifiers based on integrated circuits

Noise on the RIAA phono preAmp
Noise on the RIAA phono preAmp
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th March 2007, 07:28 PM   #1
diarav is offline diarav  India
diyAudio Member
 
Join Date: Dec 2004
Location: Bangalore India
Default Noise on the RIAA phono preAmp

Hi,
I constructed the RIAA phono preamp from ESP site.
http://sound.westhost.com/project06.htm (the single supply one - bottom of page)

The preamp board is mounted inside the turntable and is sounding fine initially. But after about 20 to 30 mins of operation, it starts giving out strange crackling noises at irregular intervals. I dont believe the problem to be attributed to any rumbling.

Could it be because I am not using a regulated supply (about 18V) at PS output. Just the 13.2V from output to Bridge rectifier to a 1000uF Electrolytic.

Or what else could cause the problem?
__________________
Regards,
Din
  Reply With Quote
Old 20th March 2007, 08:44 PM   #2
sreten is offline sreten  United Kingdom
R.I.P.
 
Join Date: Nov 2003
Location: Brighton UK
Hi,

Could be a dodgy joint. A regulator would be a good idea.
Also download the NE5332 datasheet,
the circuit does not show the PS decoupling capacitors needed.

/sreten.
  Reply With Quote
Old 20th March 2007, 08:49 PM   #3
peranders is offline peranders  Sweden
Electrons are yellow and more is better!
diyAudio Member
 
peranders's Avatar
 
Join Date: Apr 2002
Location: Göteborg, Sweden
Noise on the RIAA phono preAmp
A good RIAA amp must have a regulated _good_ power supply. Remember, you want to amplify microvolt signals as the weakest.

Despite from that, have you checked all solder joints? How about voltage ratings of your electrolytic caps? Anything gets hot?
__________________
/Per-Anders (my first name) or P-A as my friends call me
Group buy: DCT03 DC trap for big toroidal transformers. Sign up for interest HERE. 27 pcb's in interest.
  Reply With Quote
Old 23rd March 2007, 06:27 AM   #4
diarav is offline diarav  India
diyAudio Member
 
Join Date: Dec 2004
Location: Bangalore India
Thanks for your responses , peranders and sreten.

I did not check so far for any thing getting hot - this is enclosed within the turntable box and I am yet to open it.

I wanted to get inputs on possible causes before looking into it.
__________________
Regards,
Din
  Reply With Quote

Reply


Noise on the RIAA phono preAmpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help needed with noise in phono preamp duderduderini Tubes / Valves 22 31st May 2007 04:35 PM
Super fast, low noise phono preamp dioklecijan Analogue Source 30 19th July 2004 10:52 PM
Who's measured the noise on their RIAA preamp? CeramicMan Analogue Source 20 19th February 2004 07:35 PM
RIAA phono preamp using single ECC83 DJG Tubes / Valves 19 29th March 2003 03:27 PM


New To Site? Need Help?

All times are GMT. The time now is 11:01 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki