Need help fo 100w+per channel stereo chip amp - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th December 2006, 01:00 AM   #11
diyAudio Member
 
Join Date: Jan 2006
Location: Fairmount, GA
Way better than expensive stores!

The sound quality will thrill you.
__________________
Poor stereo mix? Switch to mono! Perfect.
  Reply With Quote
Old 11th December 2006, 09:18 PM   #12
diyAudio Member
 
Join Date: Oct 2006
Back on the transfo... do I need 1 or 2... I will be running this chip in parallel at 4ohms... Please give me your recommendation as for the brand and size.

Max
  Reply With Quote
Old 11th December 2006, 10:31 PM   #13
diyAudio Member
 
Join Date: Jan 2006
Location: Fairmount, GA
Normally, one transformer is used. It will have to have TWO secondaries. This is where your experienced friend should come in. Have him explain what you need in a transformer. It's the one single most expensive component. So you don't want to get the wrong one.

Either one that I linked to you will work.
__________________
Poor stereo mix? Switch to mono! Perfect.
  Reply With Quote
Old 11th December 2006, 11:57 PM   #14
diyAudio Member
 
Join Date: Oct 2006
Do you think the amp would fit with the transfo in that case ?

http://www.iagaudio.com/proddetail.asp?prod=CH%2D02
  Reply With Quote
Old 12th December 2006, 12:20 AM   #15
diyAudio Member
 
Join Date: Jan 2006
Location: Fairmount, GA
It's a beautiful case and big enoug, but you are getting ahaed of yourself.

Best to get the components and asseble the amp,then, concider an enclosure. Don't forget, you need some good heat sinks for these chips.

I lack knowledge of heatsinking techniques so, I just get the biggest I can afford. THEN, I concider the enclosure.

DON'T FORGET THIS! You must insultae the chip from the heatsink. Search Sil Pad 400 on this forum or Google.
__________________
Poor stereo mix? Switch to mono! Perfect.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: STK043 stereo amplifier chip gilwe Solid State 7 18th January 2009 07:44 AM
2-channel parallel 100W GC using LM3886 scone Chip Amps 30 28th August 2007 02:19 AM
how to mix stereo into center channel bob_v5 Solid State 0 14th February 2006 08:07 PM
Is it Chip or BJT in this Stereo Amp? boxedin Solid State 4 25th December 2005 02:44 PM
Stereo Chip Amp - one transformer or 2? groyne Chip Amps 12 18th May 2004 06:22 PM


New To Site? Need Help?

All times are GMT. The time now is 06:52 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2