diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Chip Amps (http://www.diyaudio.com/forums/chip-amps/)
-   -   Help with blown Fuses LM3886, Chipamp.com (http://www.diyaudio.com/forums/chip-amps/90802-help-blown-fuses-lm3886-chipamp-com.html)

schmalex 21st November 2006 08:59 PM

Help with blown Fuses LM3886, Chipamp.com
 
I've been working on my LM3886 chipamp for quite some time now. A few months back, it was up and running. Satisfied with the function of the amp, with little DC offset, I finished soldering all the connections, fastened the toroid and power supply board to the enclosure, and put the top and bottom on (perforated steel). I left for a few months on a research trip and I came back. Now...

My fuse blows when I turn on the amp. I've upped the durability of the fuses - I'm up to 3 amp slow-blow. I switch it on (through a power strip), the LED lights up, I hear an audible humming sound from the amp (no speakers), and it clicks off. With the slow-blow it takes slightly longer, but I'm not sure where the problem is. Any ideas? I have very little electronics knowledge. This has been a big learning curve, and I have managed to not blow myself up yet. I am at the mercy of your help.

I have a long weekend coming up, so it would be nice to finish it up.

Thanks,
Alex

You can follow my progress in these threads.
http://www.diyaudio.com/forums/showt...threadid=74843
http://www.diyaudio.com/forums/showt...threadid=60665
http://www.diyaudio.com/forums/showt...threadid=59448
http://www.diyaudio.com/forums/showt...threadid=59507
http://www.diyaudio.com/forums/showt...threadid=58594

markiemrboo 21st November 2006 09:07 PM

I'm a n00bie too, on a very steep learning curve indeed. I would guess the hum would be coming from the transformer. Might this mean a short has developed somewhere?

schmalex 21st November 2006 09:15 PM

2 Attachment(s)
inside

schmalex 21st November 2006 09:16 PM

2 Attachment(s)
bottom

schmalex 21st November 2006 09:19 PM

2 Attachment(s)
outside

davidlzimmer 21st November 2006 09:32 PM

The enclosure is too pretty!:bigeyes:

I'm sure you'll get good suggestions here. As markiemrboo suggests, it sounds like a short. Check the diodes and caps for a short.

schmalex 21st November 2006 10:56 PM

2 Attachment(s)
Thank you for the nice comment. It's really a pretty functional enclosure - it's the zebra wood that does the trick.

As for the short, the part I don't understand is that it worked fine before. I suppose when I screwed down the standoffs to the bottom piece, it could have created a short. But, the standoffs are insulated on the board from the circuit. The grounding wires off the two amp boards and the ac plug are simply twisted together and surrounded with electrical tape. Not an elegant solution, but I don't think that would cause a short.

BobEllis 21st November 2006 11:17 PM

The transformer humming indicates a short. Verify your transformer to PSU wiring. Try powering up just the transformer.

Check with an ohmmeter that your PSU input is not a short. Check each diode in the bridges. Be sure that you haven't bumped the diodes so that one is touching a neighbor. Try powering up just the PSU without the amps connected.

Could you have reversed the polarity of the PSU to amp connections? I know this is unlikely, but worth a look.

Connect one channel at a time to the PSU - after the caps have bled down.

Good luck.

ash_dac 22nd November 2006 12:27 PM

Hi,

What's the clearance above the torroidal mounting bolt ?

I see the perforated steel top and bottom , and in one of the pictures the lid looks depressed.

Is the case grounded ?

BobEllis 22nd November 2006 12:43 PM

Are there any sharp edges that could have cut the PSU leads as they run under the heat sink? How do the leads get from one side to the other?

Safety note - put some heat shrink over the mains connection terminals. I bought some 1" stuff to put over the fuse holders. Yes, I know it is there and I could avoid it but I "grew up" with tubes and got shocked enough that I am cautious.


All times are GMT. The time now is 12:14 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2