diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Chip Amps (http://www.diyaudio.com/forums/chip-amps/)
-   -   chipamp passive preamp / crossover (http://www.diyaudio.com/forums/chip-amps/88514-chipamp-passive-preamp-crossover.html)

DoomPixie 18th October 2006 09:46 PM

chipamp passive preamp / crossover
 
Hi all,
I have been toying with the idea for a while now for my "compurter room" system and tonight i started doing some experimenting. My findings are that my speakers are only good down to about 60Hz, The speakers are running from a TDA1554Q based chipamp at the moment (cheap and chearfull) which has an input impedance of about 30K (according to the datasheet).

I am in the process of building a pair of 10" active subs for the system and to begin with i want to build a passive preamp / crossover to control it all.

As an initial experiment i tried to build a 1st order passive line level crossover to filter out 100Hz and below from my main speakers. Plugged it in and as expected the level dropped a little but theres more than enough power in the system for my small room anyway so i am happy with that. the main problem i have is it dosnt seem to be filtering much if anything out.. when i play test tones through the system it seems to act the same as before but at a slightly lower level. as in it will play test tones all the way down to about 30Hz but after 60Hz the level starts to drop off and the speakers start to distort (as they did before).

The corssover used 15K resistor and 166nF capacitor (those are the values i calculated that should work to crossover at 100Hz. My question is is there something wrong with my calculations or is the 1st order crossover a complete waste of time? Or is there somethign else i am missing?

Many thanks,
Owen

preiter 18th October 2006 11:50 PM

First order just means that at 30Hz, the volume will be down 12dB from what it was at 60Hz. You may want to go with a 2nd order crossover.

sharpi31 20th October 2006 01:53 PM

Doesn't a 1st order crossover roll off at 6db per octave? This means that the output at 30Hz will be 6db less than at 60Hz, not 12db less.

Obviously the speaker is probably dropping off naturally by 30Hz, but this is a different thing...

pinkmouse 20th October 2006 02:04 PM

If the mains are ported, try blocking the ports, that might well give you another 6dB roll off, giving you something like a 12dB accoustic filter. Any better needs you to measure.

DoomPixie 23rd October 2006 10:13 PM

The speakers arent ported unfortunatley, they are based around a 6 1/2" 2 way infinity car driver in a sealed enclosure and they work really well down to about 50Hz.. but seeing as i have a sub in the system anyway i think it might be worth putting a high pass crossover on the mains..
Owen


All times are GMT. The time now is 11:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2