woofer popping sound - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 14th June 2006, 09:59 AM   #1
caw is offline caw  Australia
diyAudio Member
Join Date: Jun 2005
Location: south coast nsw
Default woofer popping sound

well i hooked up the two PS to one channel and the popping still persisted. Has any-body got any other ideas.
  Reply With Quote
Old 14th June 2006, 10:03 AM   #2
DIAR is offline DIAR  Finland
diyAudio Member
DIAR's Avatar
Join Date: Jun 2004
Location: Capital City Area
Is there an another thread about this issue or is this it?
  Reply With Quote
Old 14th June 2006, 10:03 AM   #3
diyAudio Moderator
pinkmouse's Avatar
Join Date: Apr 2002
Location: Chatham, England
Other ideas to what? Context?
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 14th June 2006, 11:33 AM   #4
diyAudio Member
raromachine's Avatar
Join Date: Jun 2006
woofer popping sound when driven hard
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does my tube amp make a scratchy, popping sound? longdrive55 Tubes / Valves 12 11th August 2009 06:48 PM
woofer popping sound when driven hard caw Chip Amps 10 8th June 2006 09:14 PM
6550 making a Popping sound? Zero Cool Tubes / Valves 4 7th November 2005 07:10 AM
occasional popping sound dsavitsk Chip Amps 6 4th May 2005 12:58 PM
popping sound when I turn my radio off feelinhipp Car Audio 2 20th April 2004 02:38 AM

New To Site? Need Help?

All times are GMT. The time now is 07:37 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2