Cambridge a1 MK3 TDA1514a chip - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th November 2005, 11:40 PM   #1
diyAudio Member
 
Join Date: Sep 2005
Default Cambridge a1 MK3 TDA1514a chip

Well my amp has burnt these transistors out but RS don't supply them anymore.

Do you know what would be a good replacement as I don't fancy getting rid of the amp, and am also one of those people who don't like to throw things out and repair them if I can.

Any help is gratefully recieved.
  Reply With Quote
Old 12th November 2005, 01:51 AM   #2
Banned
 
Join Date: Mar 2003
Location: Lisbon, Portugal
Maybe this is near you:
http://www.cricklewoodelectronics.co...401e366c60799c
  Reply With Quote
Old 12th November 2005, 03:17 PM   #3
diyAudio Member
 
Join Date: Sep 2005
Thanks but I've been told and seen on here that it will last a few weeks before poping again.

Was wondering if there was a better alternative.
  Reply With Quote
Old 12th November 2005, 08:52 PM   #4
Nuuk is offline Nuuk  United Kingdom
diyAudio Member
 
Nuuk's Avatar
 
Join Date: Feb 2003
Location: Somerset, SW England
Perhaps this may give you some inspiration!
__________________
The truth need not be veiled, for it veils itself from the eyes of the ignorant.
  Reply With Quote
Old 12th November 2005, 10:29 PM   #5
johnnyx is offline johnnyx  United Kingdom
diyAudio Member
 
Join Date: Jan 2004
Location: manchester
Quote:
Originally posted by katanassn
Thanks but I've been told and seen on here that it will last a few weeks before poping again.

Why is that, what's the problem?
  Reply With Quote
Old 15th November 2005, 10:06 PM   #6
diyAudio Member
 
Join Date: Sep 2005
don't know what the problem is. The repair shop bloke i bought the fuses from told me that his experience usually the chips blow up again shortly afterwards with the non uk made cambridge amps
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Exploding TDA1514A problem mobyd Chip Amps 2 15th March 2008 06:40 AM
.. are TDA1514a **** or what ..?? tmyr Chip Amps 1 1st December 2006 08:06 PM
TDA1514a amp jez Chip Amps 5 17th April 2006 09:19 PM
TDA1514A Mute/Stby? Dxvideo Chip Amps 4 9th October 2005 11:00 AM
About TDA7250/TDA1514A MaXiZ Chip Amps 11 7th December 2003 06:55 AM


New To Site? Need Help?

All times are GMT. The time now is 04:18 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2