Basic Inverted Gain Clone - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th June 2005, 03:30 AM   #1
caw is offline caw  Australia
diyAudio Member
 
Join Date: Jun 2005
Location: south coast nsw
Question Basic Inverted Gain Clone

Hello, i am a first time di your-selfer building an inverted gain clone. I finished the psu and one channel and decided to try it out so as not to double up on my mistakes on the second one.The psu is putting out 37 vdc each rail.When i powed up the LM3875t chips No1 terminal heated up and broke off,also leaving the backing plate to the chip heat affected.Could any-body give me some advice on how to rectify the problem please.

Thanks,Clive
  Reply With Quote
Old 8th June 2005, 03:58 AM   #2
diyAudio Member
 
Join Date: Jul 2004
Location: BC, Canada
What were you using for a heatsink? Do you have V+ and V- reversed?
  Reply With Quote
Old 8th June 2005, 06:51 AM   #3
caw is offline caw  Australia
diyAudio Member
 
Join Date: Jun 2005
Location: south coast nsw
The heatsink is a piece anodised aluminium 45x40mm with fins.I had the positive wire going to pin No1
  Reply With Quote
Old 8th June 2005, 06:51 AM   #4
caw is offline caw  Australia
diyAudio Member
 
Join Date: Jun 2005
Location: south coast nsw
Just hooked every-thing up again, every-thing seems to be fine.Must have been a fractured terminan.I do get a reading of 16.4mvdc across the speaker terminals with a 10 ohm resister bridging them.Is that alright.
Much apreciate your help.Clive.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Optimum gain for Inverted OPA-541 AP 100db Chip Amps 6 27th July 2006 11:35 AM
Inverted GainClone's gain question? 5150ed Chip Amps 15 10th July 2006 08:12 AM
Inverted gain clone power amp only? tubenut Chip Amps 1 26th March 2004 08:28 AM
non-inverted LM3875 Gain clone - are these components cool or funky? chipco3434 Chip Amps 2 11th March 2004 01:35 PM
Bridging inverted clone: Help! Keui? sangram Solid State 9 19th February 2003 04:22 AM


New To Site? Need Help?

All times are GMT. The time now is 07:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2