Speaker connections? - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th March 2004, 03:15 AM   #1
diyAudio Member
 
Join Date: Jan 2004
Location: Irondale, AL
Question Speaker connections?

Has anybody had any experience with Speak-On (sp?) connectors? The premise is good, but can't find anything about how they sound(or don't, hopefully).
I don't relish the cost or maintenance of the Canares Cu or Patent pending models.

I figured it was about to open a new can of worms and let Brian rest up for his wedding

Lee
__________________
Been there, Heard that, Forgot what I was listening to!
  Reply With Quote
Old 5th March 2004, 08:27 AM   #2
Nuuk is offline Nuuk  United Kingdom
diyAudio Member
 
Nuuk's Avatar
 
Join Date: Feb 2003
Location: Somerset, SW England
Quote:
Has anybody had any experience with Speak-On (sp?) connectors?
Quite a few of us use them as power supply connectors. They are a very high quality connector and I would guess they are as good as anything for connecting speakers.

I don't use them myself for speakers, preferring to make my own connectors (see my Gainclone pages )
__________________
The truth need not be veiled, for it veils itself from the eyes of the ignorant.
  Reply With Quote
Old 5th March 2004, 03:33 PM   #3
diyAudio Member
 
Matttcattt's Avatar
 
Join Date: Feb 2003
Location: Bristol
Quote:
Originally posted by Nuuk


Quite a few of us use them as power supply connectors. They are a very high quality connector and I would guess they are as good as anything for connecting speakers.

I don't use them myself for speakers, preferring to make my own connectors (see my Gainclone pages )

im using them for power connectors in my amps as well, they look really good.
__________________
If it aint broke, don't fix it. If it is broke, fix it.
If you can't fix it, take it apart and see how it "worked".
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
43% UL connections Hojvaelde Tubes / Valves 18 23rd June 2009 12:00 AM
internal speaker connections - newbie question speakerbug Parts 6 29th February 2008 03:12 PM
Question on Alpine MRP-M450 speaker connections Flyin11 Car Audio 3 8th November 2007 01:25 AM
SubD as speaker-connections TroelsM Multi-Way 0 11th July 2007 10:44 AM


New To Site? Need Help?

All times are GMT. The time now is 02:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2