Speaker/chip amp 'compatibility? - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th January 2014, 10:21 AM   #1
fap is offline fap  Australia
diyAudio Member
 
Join Date: Sep 2010
Location: North Queensland.
Default Speaker/chip amp 'compatibility?

G'day all, I've recently encountered a very strange speaker/chip amp compatibility issue that is nothing short of bizarre!

A set of Jaycar JV60 speakers that I recently purchased pre-assembled simply will not work with my old reliable LM3886 amplifier (the ESP P19 design), without producing severe audio distortion (well below clipping), yet my existing good quality bookshelf speakers work fine without 'any' distortion with this same LM3886 amplifier!

However the same JV60's work fine with a lower power chip amp using an LM1875T chip. I simply cannot think of any technical reason why the JV60's will not apparently work with my LM3886 amplifier! Could there be some kind of curious speaker/chip amplifier incompatibility? Regards, Felix.
  Reply With Quote
Old 27th January 2014, 10:22 AM   #2
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Have you fitted all the stability enhancing "optional" components to both versions of your chipamps?

Have you fitted the two input filters to both versions of your chipamps?
__________________
regards Andrew T.
  Reply With Quote
Old 27th January 2014, 10:26 AM   #3
fap is offline fap  Australia
diyAudio Member
 
Join Date: Sep 2010
Location: North Queensland.
G'day mate, yes all stability components have been included in my construction as far as I can recall. Yes, it's a strange one! Regards, Felix.
  Reply With Quote
Old 27th January 2014, 10:47 AM   #4
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
which construction includes all the "optional" components?
__________________
regards Andrew T.
  Reply With Quote
Old 27th January 2014, 10:52 AM   #5
fap is offline fap  Australia
diyAudio Member
 
Join Date: Sep 2010
Location: North Queensland.
G'day mate, this one, it's actually the LM3876! Single Chip 50W Stereo Amplifier Regards, Felix.
  Reply With Quote
Old 27th January 2014, 11:12 AM   #6
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Can you check for oscillation?
can you add a 0r22 power resistor to the output after the Zobel?
__________________
regards Andrew T.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3 way driver compatibility check: first time speaker builder fishish1 Multi-Way 18 21st September 2011 06:39 PM
Chip amp to use with Tivoli speaker kenneth Chip Amps 4 17th February 2009 09:07 AM
Best Chip amp for this 4 Ohm speaker 100db Chip Amps 14 29th September 2006 12:45 AM
Gainclone -- speaker, cable compatibility??? greg7 Chip Amps 17 20th May 2003 09:49 AM


New To Site? Need Help?

All times are GMT. The time now is 04:59 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2