Technics SA310 - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th August 2013, 02:37 AM   #1
diyAudio Member
 
Join Date: Aug 2013
Default Technics SA310

Hey all-just to preface, I am far from a Novice as it comes to basic electronics, but not afraid to give it a try with experts like you holding my hand. I've saw a couple of threads related to the unit I have and hopeful for some guidance: I've owned this unit from new. It's been in storage and not powered up since the late 90's and always played well. I broke it out recently and hoped it would power up and no such luck. No lights, no sign that its alive. I've pulled the main cover off and checked the fuse by the power switch. All looks good. I lack the basic power meter to test power to the unit, but believe power is coming in: I had an accessory plugged into the accessory power plug on the back of the unit and it powered up well. Honestly the components look real good, no burn marks, boards look good, hardly any dust. i found some corrosion in the AA Battery location, i had pulled the batteries out years ago and was surprised to see some blue corrosion. there wasnt a lot of it, but it was there.
Can one of you guys point me in the right direction? I'd love to see this unit power back up again and hope to do so with little cost thanks in advance for your help. Coop
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which Technics is best K12pfc Solid State 0 3rd May 2013 06:00 AM
Technics Turntable Rte 66 Dave Analogue Source 3 4th April 2013 06:48 AM
Technics Trouble microtouch Chip Amps 1 1st June 2007 05:49 AM
Technics SL-5 pinkmouse Analogue Source 22 5th July 2006 10:59 AM
Technics SA310 Schematic gand0lph Solid State 1 9th May 2004 02:49 PM


New To Site? Need Help?

All times are GMT. The time now is 04:49 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2