Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd April 2013, 03:58 AM   #11
fap is offline fap  Australia
diyAudio Member
 
Join Date: Sep 2010
Location: North Queensland.
G'day all, just an update. It's fixed and working well again. The fault turned out to be one faulty LM1875T and I replaced both for the sake of uniformity, one bridge rectifier (one diode was shorted) and one leaky electrolytic filter capacitor.

The originals were working every day since about 2005 so that's a pretty good lifetime. I don't know what failed first but here's hoping for another good few years of normal operation. Thanks to all here for their help with fault finding on this. Regards, Felix.
  Reply With Quote
Old 3rd April 2013, 06:33 AM   #12
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Thanks for the update. Great news to hear you have fixed it
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chip Amps and Pre Amps bcmbob Chip Amps 17 13th August 2010 09:38 AM
Chip amps vs class D amps lanchile Chip Amps 46 21st April 2010 04:38 AM
New to Chip Amps skidave Chip Amps 14 28th July 2007 06:15 PM
Help... Need Chip amps game_master Chip Amps 1 9th March 2006 03:14 PM
Has anyone compared the Chip amps against Class T amps? soongsc Chip Amps 3 24th July 2005 11:50 AM


New To Site? Need Help?

All times are GMT. The time now is 12:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2