preamp volume control help needed - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th November 2003, 03:07 AM   #1
pundip is offline pundip  Australia
diyAudio Member
 
pundip's Avatar
 
Join Date: Jan 2003
Location: Melbourne
Exclamation preamp volume control help needed

I have built the following amp. The preamp section was added because I was not happy with the gain from the power section. The preamp seems to be able to provide enough signal to drive the power section but I cannot get the volume control to work properly. I am aware that the volume pot needs to be logarithmic or a 15k resistor needs to be added from tapper to ground which I intend to do but as is there are two major problems.
1. When the volume control is on minimum the sound is distorted with a lack of bass.
2 The volume control offers no control after its turned 25% up. It reaches its maximum..
I intend to use a variety of inputs sources ranging from a proper CD player to pc soundcard to TV headphone out.

pics woulnt load so here are the links
schematic http://www.pundip.com/amp/amp.gif
guts and mis pics http://www.pundip.com/amp/

I need advice on what is the best type of volume control I can use. Is locating the pot between pre and power sections of the amp a good idea?

Also please keep in mind I have no formal electronics background and I have managed to come this far only because of this forum and advice from members.

Thanks in advance.
  Reply With Quote
Old 7th November 2003, 03:52 AM   #2
diyAudio Member
 
BobEllis's Avatar
 
Join Date: Sep 2003
Location: Upstate NY
Three things I'd try:

First, bigger coupling caps - maybe 2 uf or 4.7. You've got a hiigh pass filter on the input with a -3db point of 16 hz. You should be able to do away with the one after the volume control. You could parallel it with teh input cap and see if that improves the bass response.

I'd also try reducing the input stage gain by increasing the 1K resistor from the +input to ground to 2K or so. You may be overdriving the input stage causing your low volume distortion.

Lastly, replace the pot with an audio taper/ logarithmic taper. With a linear taper 25% of the way up is about -6db from full output. It is actually getting more drive from there on up, but you may have too much distortion to notice. You can approximate a log taper pot by placing a resistor from the top (ungrounded end) of the pot to the wiper (line to the 3886). I cannot remember how big, but try 10-20K. maybe someone else can tell you what it should be.

You didn't forget to make a connection from the mute pin to the - rail, did you? put a 10K there.

Hope this helps.
  Reply With Quote
Old 12th November 2003, 10:09 PM   #3
B.VDBOS is offline B.VDBOS  New Zealand
diyAudio Member
 
B.VDBOS's Avatar
 
Join Date: Aug 2003
Location: Auckland, New Zealand
I think the opa2134 may be clipping, most c.d players ect. put out about 2 volts, with that opa2134 set to a gain of 10 (R1k, R10k) it will try to output a 20 volt sinal with only 15 volts of supply power so you will only be getting distortion, try temporally disconecting Rk1 on the opa (this will reduce the gain from 10 to 1) to see if the distortion goes away.
The lm3886 with R1k and R20k should only need a 1 volt signal to achieve maximum output power, so if your not getting enough gain I dont think using the opa to increase the input signal will help, the problem may be something else
  Reply With Quote
Old 12th November 2003, 10:29 PM   #4
B.VDBOS is offline B.VDBOS  New Zealand
diyAudio Member
 
B.VDBOS's Avatar
 
Join Date: Aug 2003
Location: Auckland, New Zealand
Looking agian at the scamatic the opa is wired wrong, The feed back network (R1k R10k) should be going to the - pin (2) and the input should be going to the + pin (3)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i add volume control to a preamp merickrc Chip Amps 0 23rd March 2009 03:02 AM
X-preamp volume control MBK Pass Labs 45 3rd July 2008 10:14 PM
i need preamp schematics w/o tone control or volume control hernanstafe Parts 7 30th January 2008 04:12 AM
Need Preamp with Volume Control ASAP! b0nk3rs Solid State 23 4th January 2007 08:48 AM
Preamp volume control?? Craig405 Tubes / Valves 7 10th September 2005 11:32 AM


New To Site? Need Help?

All times are GMT. The time now is 11:02 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2