Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th June 2012, 09:06 AM   #1
diyAudio Member
 
viktor89's Avatar
 
Join Date: May 2011
Location: Copenhagen
Send a message via Skype™ to viktor89
Question Issue with Arjen Helder monoamps and minidsp

Hi all

I am having some problems with my amplifier & minidsp and I was really hoping to get some help here.

I have connected my minidsp with 2 arjen helder monoamps (these: PAIR OF MKII STA508 Tripath 100W monoblock amplifier | eBay )

I have tested each amplifier seperately - works fine. I have tested the dsp with a Muse M20 EX2 amp - works fine.

I have attached a screenshot of my setup.

When I power it up, i just get a continueous "noise". Best described as a windy sound - kinda like when you put your ear to a conch (just louder, though). I do not understand what could be wrong... Any suggestions?

It seems as though my amplifiers doesn't "understand" the minidsp signal, but has no issues with a direct signal from ipod/iphon/etc

The box in the top right corner is a 12v - 24v dc-dc converter (this one: 240W Car DC 12V to DC 24V Step Up DC DC Converter ! | eBay )

Thanks in advance!
Attached Images
File Type: jpg 30-05-2012 13-34-43.jpg (90.7 KB, 240 views)
File Type: jpg 123o744.jpg (95.0 KB, 233 views)
  Reply With Quote
Old 19th June 2012, 11:24 AM   #2
diyAudio Member
 
Join Date: Feb 2011
Can You borrow some batterys to test the setup without that step up converter?
that looks fishy to mee.
  Reply With Quote
Old 19th June 2012, 11:31 AM   #3
diyAudio Member
 
viktor89's Avatar
 
Join Date: May 2011
Location: Copenhagen
Send a message via Skype™ to viktor89
I could test it in 12v? Would that do?
  Reply With Quote
Old 19th June 2012, 08:46 PM   #4
diyAudio Member
 
Join Date: Feb 2011
sure, if the amps and dsp can run on 12v , then its fine.
battery power would be the best.
then test dsp on inverter, amps on battery.
then dsp on battery and amps on inverter.

this will help find out what is the problem.
  Reply With Quote
Old 19th June 2012, 08:55 PM   #5
diyAudio Member
 
Join Date: Aug 2010
Seems like you are setting up a car Stereo. You should use the miniDC Isolator to avoid any noise problems from car electronics and inverter.
With respect to your Setup maybe stray field from the amplifiers can cause some noise in the miniDSP. Did you try moving the DSP away from the amps?

Send with Tapatalk from my Defy+
  Reply With Quote
Old 21st June 2012, 09:43 AM   #6
diyAudio Member
 
viktor89's Avatar
 
Join Date: May 2011
Location: Copenhagen
Send a message via Skype™ to viktor89
It is not being used in a car.

I tested without the converter and I have no sound at all. I also tried using 24 v on the entire setup - still no sound. I will do some more testing according to the suggestions tonight. Anybody got more suggestions for tests that I should run?
  Reply With Quote
Old 21st June 2012, 06:35 PM   #7
diyAudio Member
 
Join Date: Feb 2011
yes, try the amps on battery power without the mini dsp, seems they might be FUBAR
  Reply With Quote
Old 21st October 2012, 09:18 PM   #8
stenak is offline stenak  Norway
diyAudio Member
 
Join Date: Nov 2009
Default Helder STA 508

Quote:
Originally Posted by Arty View Post
yes, try the amps on battery power without the mini dsp, seems they might be FUBAR
I have a pair of the Helder STA 508. Think I going to use a smps 24v/6A for both channels. Should I buy a transformer with two 18v windings, some Rectifier Bridges , and a couple of Rifa 4700mF on each channel instead?


[Review] Helder HiFi STA508 Monoblock amplifier - [English]
  Reply With Quote
Old 27th October 2012, 08:04 PM   #9
diyAudio Member
 
Join Date: Feb 2011
look up a tipical gainclone psu and copy it.
most probably you are going to be better with that.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arjen Helder Buffer V2 Zero One Class D 72 19th May 2013 12:45 AM
Arjen Helder tube pre on ta2020 and maybe a MINIDSP? JOHNNYFAMOUS Class D 23 25th August 2012 01:47 AM
Good Experience with Arjen Helder mfong Class D 6 10th May 2011 07:07 PM
Arjen Helder amp for TV Kjeldsen Class D 2 6th April 2011 05:43 AM
Where is Arjen Helder steveww Class D 6 5th October 2010 06:32 PM


New To Site? Need Help?

All times are GMT. The time now is 02:19 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2