sick amp please help - Page 3 - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th November 2011, 07:22 PM   #21
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Your Maplin amp kit will have come with it's own build guide and spec sheet.
__________________
regards Andrew T.
  Reply With Quote
Old 6th September 2012, 08:47 PM   #22
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Quote:
Originally Posted by richa View Post
hi everyone,
i have built ("from kits") a pair of maplin 50 watt mono blocks with uprated power supplies,(individual to each channel,) and a pre amp, they are rather goood, these are kit amps and i merely followed the instructions but when it comes to troubleshooting i'm a bit lost. could anyone give any help on the indie repair, there is no point buying anything else as i'm sure it must be a simple repair, anyway thanks in advance for any help you can give,,
I have just bought a couple of Maplins 50 watt amps off ebay one working and one with some transistors missing.
The working one was oscillating a bit so I add 150pf to the VAS and it works great now.
I first built one of these in around 1980 for a disco but it wasnt really loud enough so I bought one of Maplins 225WRMS amplifiers and that was very loud.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sick Carver M-1.0t amp: bad caps? sblack6 Solid State 1 7th June 2009 07:53 AM
Got this on this on ebay..sick amp benny_rx_blanco Car Audio 2 8th April 2009 10:18 PM
New sick amplifier Solosound Car Audio 3 5th December 2008 01:29 AM
My Fender 6G15 is sick bassman314 Instruments and Amps 8 29th January 2007 02:54 PM
Help - Z4 sick on startup BeaufortRalph Pass Labs 5 18th April 2005 06:50 PM


New To Site? Need Help?

All times are GMT. The time now is 12:00 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2